Cups do not restart after logrotate

General support questions including new installations
Post Reply
maufacc
Posts: 2
Joined: 2010/06/28 12:21:15

Cups do not restart after logrotate

Post by maufacc » 2010/06/28 12:49:27

I've installed cups version from centos repositories, on an SME Server 7.4, that is based on Centos 4.8. Cups is not part of SME SErver, so despite I've asked on SME Forums, I guess there are not much users that knows about cups in that forums.

After logrotate of cups, something goes wrong, and as I can see it cannot finish to restart. Reinstalling the package solve the trouble till the next logrotate

Logrotate configuration

[code]
/var/log/cups/access_log /var/log/cups/error_log {
missingok
notifempty
sharedscripts
postrotate
/etc/init.d/supervise/cupsd sigterm >/dev/null 2>&1 || true
endscript
}
[/code]

[code]
/var/log/samba/*.log {
notifempty
missingok
sharedscripts
copytruncate
postrotate
/bin/kill -HUP `cat /var/run/smbd.pid /var/run/nmbd.pid /var/run/winbindd.pid 2> /dev/null` 2> /dev/null || true
endscript
}
[/code]
Installed version

[code]
cups.i386 1:1.1.22-0.rc1.9.32.el installed
samba.i386 3.0.33-0.18.el4_8.1 installed
[/code]

[code]
I [27/Jun/2010:04:02:07 -0300] Listening to 7f000001:631
I [27/Jun/2010:04:02:07 -0300] Listening to c0a8007e:631
I [27/Jun/2010:04:02:07 -0300] Loaded configuration file "/etc/cups/cupsd.conf"
I [27/Jun/2010:04:02:07 -0300] Configured for up to 100 clients.
I [27/Jun/2010:04:02:07 -0300] Allowing up to 100 client connections per host.
I [27/Jun/2010:04:02:07 -0300] Full reload is required.
E [27/Jun/2010:04:02:07 -0300] Unknown configuration directive StateTime on line 8 of printers.conf.
E [27/Jun/2010:04:02:07 -0300] Unknown configuration directive StateTime on line 21 of printers.conf.
I [27/Jun/2010:04:02:07 -0300] LoadPPDs: Read "/etc/cups/ppds.dat", 1272 PPDs...
I [27/Jun/2010:04:02:07 -0300] LoadPPDs: No new or changed PPDs...
I [27/Jun/2010:04:02:08 -0300] Full reload complete.
....
[/code]
At 6:00 I make a cupsenable to all printers, that works fine all days except on sunday after the logrotate.

[code]
I [27/Jun/2010:06:00:01 -0300] Printer 'almacen' started by 'root'.
I [27/Jun/2010:06:00:01 -0300] Saving printers.conf...
I [27/Jun/2010:06:00:01 -0300] Printer 'barras' started by 'root'.
I [27/Jun/2010:06:00:01 -0300] Started backend /usr/lib/cups/backend/smb (PID 10912) for job 2460.
I [27/Jun/2010:06:00:01 -0300] Printer 'Brother_trali' started by 'root'.
I [27/Jun/2010:06:00:01 -0300] Printer 'epson_mauro' started by 'root'.
I [27/Jun/2010:06:00:01 -0300] Saving printers.conf...
I [27/Jun/2010:06:00:01 -0300] Printer 'fact_merbe' started by 'root'.
I [27/Jun/2010:06:00:01 -0300] Listening to 7f000001:631
I [27/Jun/2010:06:00:01 -0300] Listening to c0a8007e:631
I [27/Jun/2010:06:00:01 -0300] Loaded configuration file "/etc/cups/cupsd.conf"
I [27/Jun/2010:06:00:01 -0300] Configured for up to 100 clients.
I [27/Jun/2010:06:00:01 -0300] Allowing up to 100 client connections per host.
I [27/Jun/2010:06:00:01 -0300] Full reload is required.
E [27/Jun/2010:04:02:07 -0300] Unknown configuration directive StateTime on line 8 of printers.conf.
......
E [27/Jun/2010:04:02:07 -0300] Unknown configuration directive StateTime on line 189 of printers.conf.
I [27/Jun/2010:06:00:01 -0300] LoadPPDs: Read "/etc/cups/ppds.dat", 1272 PPDs...
I [27/Jun/2010:06:00:01 -0300] LoadPPDs: No new or changed PPDs...
I [27/Jun/2010:06:00:02 -0300] Full reload complete.
I [27/Jun/2010:06:00:02 -0300] Started backend /usr/lib/cups/backend/smb (PID 10942) for job 2460.
I [27/Jun/2010:06:00:03 -0300] Listening to 7f000001:631
I [27/Jun/2010:06:00:03 -0300] Listening to c0a8007e:631
I [27/Jun/2010:06:00:03 -0300] Loaded configuration file "/etc/cups/cupsd.conf"
I [27/Jun/2010:06:00:03 -0300] Configured for up to 100 clients.
I [27/Jun/2010:06:00:03 -0300] Allowing up to 100 client connections per host.
I [27/Jun/2010:06:00:03 -0300] Full reload is required.
E [27/Jun/2010:06:00:03 -0300] Unknown configuration directive StateTime on line 8 of printers.conf.
.......
E [27/Jun/2010:06:00:01 -0300] Unknown configuration directive StateTime on line 187 of printers.conf.
I [27/Jun/2010:06:00:01 -0300] LoadPPDs: Read "/etc/cups/ppds.dat", 1272 PPDs...
I [27/Jun/2010:06:00:01 -0300] LoadPPDs: No new or changed PPDs...
I [27/Jun/2010:06:00:02 -0300] Full reload complete.
I [27/Jun/2010:06:00:02 -0300] Started backend /usr/lib/cups/backend/smb (PID 10942) for job 2460.
I [27/Jun/2010:06:00:03 -0300] Listening to 7f000001:631
I [27/Jun/2010:06:00:03 -0300] Listening to c0a8007e:631
II [27/Jun/2010:06:00:01 -0300] LoadPPDs: Read "/etc/cups/ppds.dat", 1272 PPDs...
I [27/Jun/2010:06:00:01 -0300] LoadPPDs: No new or changed PPDs...
I [27/Jun/2010:06:00:02 -0300] Full reload complete.
I [27/Jun/2010:06:00:02 -0300] Started backend /usr/lib/cups/backend/smb (PID 10942) for job 2460.
I [27/Jun/2010:06:00:03 -0300] Listening to 7f000001:631
I [27/Jun/2010:06:00:03 -0300] Listening to c0a8007e:631
[/code]
log.smbd

[code]
[2010/06/27 04:02:17, 1] smbd/server.c:open_sockets_smbd(491)
Reloading services after SIGHUP
[2010/06/27 06:00:25, 0] printing/print_cups.c:cups_connect(69)
Unable to connect to CUPS server localhost:631 - Connection refused
[2010/06/27 06:20:25, 0] printing/print_cups.c:cups_connect(69)
Unable to connect to CUPS server localhost:631 - Connection refused
[/code]

[Moderator edited to insert [i]code[/i] tags to preserve the format and to ease reading of the post.]

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Cups do not restart after logrotate

Post by pschaff » 2010/06/28 21:27:12

Welcome to the CentOS fora. The following reading is recommended for new users:
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14274&forum=47]Readme First[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14408&forum=47]Installing Software[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14273&forum=47]Where to Find Answers[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=25128&forum=47]How to provide information about your system[/url]

[quote]
maufacc wrote:
I've installed cups version from centos repositories, on an SME Server 7.4, that is based on Centos 4.8. Cups is not part of SME SErver, so despite I've asked on SME Forums, I guess there are not much users that knows about cups in that forums.
...[/quote]

I can only guess that although [url=http://wiki.contribs.org/SME_Server:Download]SME Server[/url] is based on CentOS it is not CentOS, and is not compatible with the cups package you have installed. It also seems 7.4 is an obsolete release based on CentOS 4.7, as their current 4.8-based release is 7.5.1.

Please see
[url=http://wiki.centos.org/AdditionalResources/OtherVoices]Other Voices[/url]
[url=http://wiki.centos.org/TipsAndTricks/BrokenSpins]When CentOS Is Not CentOS[/url]

If you want to install a fresh CentOS system then we can help you; however, we can't help much with a broken non-CentOS system, and advice from here might just break it worse. Sounds like a case of "If you break it you get to keep all the pieces."

maufacc
Posts: 2
Joined: 2010/06/28 12:21:15

Re: Cups do not restart after logrotate

Post by maufacc » 2010/06/29 14:29:19

Thank you for your response, and thank you for quoting my previous message.
I understand that mixing systems can break the consistency of the system. I do not understand why the system works fine and breaks when it logrotate.
I will try to install a parallel system, and try to delay the cups logrotate from the samba logrotate.

Post Reply

Return to “CentOS 4 - General Support”