Third party device driver install during PXE based kickstart

General support questions including new installations
Post Reply
Slowcrow
Posts: 2
Joined: 2008/05/21 23:40:16

Third party device driver install during PXE based kickstart

Post by Slowcrow » 2008/05/21 23:53:15

Hi all,
We have a relatively large kickstart installation which works flawlessly for most of our needs. We have however run into a hitch. We recently bought some servers that have a RAID controller that requires a driver disk to be used during the installation process. Not a big deal if you are doing manual installations or manual kickstart-based installations. The problem I've run into is this: I'm unable to automatically load the device driver disk image so that an unattended kickstart installation can occur.

Here's what I've tried so far:

Adding this to the ks.cfg:

driverdisk --source nfs:10.20.20.10:/kickstart/drivers/dd.img (both in %pre and not in %pre)

Totally ignored.

Tried using http instead

driverdisk --source http://10.20.20.10/drivers/dd.img (both in %pre and not in %pre)

The web server logs don't even show a hit trying to pull it down.

I verified both locations by hand and I can indeed see the files in their respective locations.


I modified the boot lines in the pxe configs to have dd in it for the version of CentOS I'm trying to install (4.5 due to the driver being for 4.5) i.e.:

kernel centos4.5/vmlinuz
append initrd=centos4.5/initrd.img ramdisk_size=8192 ks=nfs:10.20.20.10:/kickstart/ks-configs/centos4.5.ks.cfg ksdevice=eth1 dd

This makes it ask me for a device driver disk which I can happily provide via a USB key.

That in combination with the ks.cfg mods aren't doing what I'm hoping which is.. it will load the driver automatically and merrily continue on its way.

Any hints on what I'm doing wrong or missing would be appreciated.

And yes.. the pxe kickstart environment works completely 100% except for this new kink.


Thanks,
Carl

Post Reply

Return to “CentOS 4 - General Support”