Dell Serial Console Requires Terminal Reset

General support questions including new installations
Post Reply
mselby
Posts: 3
Joined: 2005/04/12 10:57:53
Contact:

Dell Serial Console Requires Terminal Reset

Post by mselby » 2005/04/12 11:58:14

I manage a cluster of servers (Both Compaq and Dell) that are kickstarted quite often via serial console. The Dell machines have thier BIOS set to console redirection on and console redirection after boot off.

Under all 2.4 kernels this worked just the way it was needed.

With my move to Centos4 and the 2.6 kernel I have encountered a small problem only with my Dell hosts around the serial console. This problem is worst when I am kickstarting a server.

serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
%G�� %@ýý
ý<°(<ýýNýýýýýý8ý├Gô?ý.ýýýFNýýýý├ý8┼5ýýýWýýNýWýý│Nýýý5ý28ýýý
ý│ýGýý│ýC %G��� %@ %G� %@G±
M %Gâ�� %@┤┼├ デâ��â�� ダ / %Gâ�� %@SCSI %Gâ�� %@┤ デâ��â�� ダ≤ Ηâ�� �├ デâ�� ダ└ %Gâ�� %@┼ デâ�� ダ├ デâ�� ダ▒┌ デâ�� ダ≥ Ηâ��â�� �

During the system load right after the Serial: 8250/16550 driver inits, the terminal on all my Dell servers gets "garbled" and I have to perform a terminal reset in order to get readable characters back. Sometimes if I do not do this fast enough the terminal process will go into a spin loop and I will have to kill it. THIS DOES NOT HAPPEN WITH COMPAQ SERVERS.

On a normal boot while the serial init does mess up the terminal it does seem to recover to normal characters most of the time further in the boot process. The screen during a kickstart never reverts to normal characters unless a terminal reset is performed.

Has anyone else seen this behaviour on a Dell server and figured out a way to change the way the serial port initializes to aviod the screen being garbled and the need for a terminal reset?

Thanks!

Post Reply

Return to “CentOS 4 - General Support”