SSH and FTP access

General support questions including new installations
Post Reply
hm8941
Posts: 5
Joined: 2005/04/12 00:52:26

SSH and FTP access

Post by hm8941 » 2005/04/12 01:00:54

I have a new install of centos4 and I cannot get SSH or FTP access to work. I know that it is not the firewall, because I have turned it completely off. xinitd is started and running. Does anyone have any ideas on what Im missing? Im sure its something simple, but I sure dont seem to be able to find it. Thanks in advance.

Howard

greensky
Posts: 3
Joined: 2005/04/12 06:20:14
Contact:

Re: SSH and FTP access

Post by greensky » 2005/04/12 06:31:53

Hello Howard,

I hope this helps.... Here are two things to test:

1. Make sure ssh is running:

Login to your server as root and type: "ps -aux | grep sshd"

You should see a line like: "root 1871 0.0 0.3 4820 1664 ? Ss 21:59 0:00 /usr/sbin/sshd"

If you don't then your ssh server isn't running. You can start it by typing "/etc/init.d/sshd start" or running system-config-services and setting it up there.

2. Double check the firewall:

What happens when you telnet to your server like this: telnet xxx.xxx.xxx.xxx 22

Do you see something like this:
telnet: connect to address xxx.xxx.xxx.xxx No route to host

or something like this:
Connected to xxx.xxx.xxx.xxx (xxx.xxx.xxx.xxx).
Escape character is '^]'.
SSH-1.99-OpenSSH_3.9p1

If you see the second message you know that your firewall is open and sshd is running. Let me know if you still can't get in.

Peace,

-Cory

hm8941
Posts: 5
Joined: 2005/04/12 00:52:26

Re: SSH and FTP access

Post by hm8941 » 2005/04/12 12:15:52

Ok, I grep'd for SSH and its running. To take the firewall out of the loop, I tried to ftp from the box itself, and here is what I got.

[root@localhost ~]# ftp localhost
Connected to localhost.localdomain.
220 localhost.localdomain FTP server (Version 5.60) ready.
334 Using authentication type GSSAPI; ADAT must follow
GSSAPI accepted as authentication type
GSSAPI error major: Miscellaneous failure
GSSAPI error minor: No credentials cache found
GSSAPI error: initializing context
GSSAPI authentication failed
334 Using authentication type KERBEROS_V4; ADAT must follow
KERBEROS_V4 accepted as authentication type
Kerberos V4 krb_mk_req failed: You have no tickets cached
Name (localhost:root):


To the best of my knowledge, I do not have kerberos enabled. Thanks again for your help.

Howard

greensky
Posts: 3
Joined: 2005/04/12 06:20:14
Contact:

Re: SSH and FTP access

Post by greensky » 2005/04/12 15:47:36

Howard,

Good idea on the firewall. I'm not familiar with ftp but this seems like it might help:
http://www.linux-tutorial.info/ftopict-181.html

What error do you get when you try to ssh into your machine?

-Cory

hm8941
Posts: 5
Joined: 2005/04/12 00:52:26

Re: SSH and FTP access

Post by hm8941 » 2005/04/13 01:50:01

When Im on the box and I try to connect to the box via SSH(thus eliminating the firewall), here is what I get:

[hm8941@localhost ~]$ ssh localhost
The authenticity of host 'localhost (127.0.0.1)' can't be established.
RSA key fingerprint is 81:f8:8a:10:e3:f8:3c:53:aa:4a:2d:42:49:b0:5a:b4.
Are you sure you want to continue connecting (yes/no)? y
Please type 'yes' or 'no': yes
Warning: Permanently added 'localhost' (RSA) to the list of known hosts.
hm8941@localhost's password:
Last login: Tue Apr 12 20:40:49 2005 from adsl-208-190-219-199.dsl.stlsmo.swbell.net


I donno if that helps, but it might. Thanks again for all your help.

Howard

greensky
Posts: 3
Joined: 2005/04/12 06:20:14
Contact:

Re: SSH and FTP access

Post by greensky » 2005/04/13 04:00:08

Do you not get a command prompt after the "Last login:..."? That's the last thing you should see before you get a command prompt and are logged in.

If you don't get to a command prompt make sure your shell is setup properly by setting it: "chsh -s /bin/bash hm8941". You'll have to do that as root.

Also, did that link I posted help at all?

-Cory

Post Reply

Return to “CentOS 4 - General Support”