Can't upgrade CentOS3.4 -> CentOS4?

General support questions including new installations
Post Reply
axon-obriend
Posts: 4
Joined: 2005/03/20 16:43:59
Location: Alexandria, VA
Contact:

Can't upgrade CentOS3.4 -> CentOS4?

Post by axon-obriend » 2005/03/20 17:40:28

Am I missing something? I've got a recently built CentOS 3.4 system that I want to upgrade to CentOS 4 via downloaded CDs. When I boot from CD #1, however it says "Searching for previous CentOS 4.0 installations..." and then prompts me for the install type (workstation, server, custom...).

To be honest, I usually rebuild systems from scratch, but I thought I'd take it through the upgrade process this time, since I have a couple of Fedora systems I'd like to update instead of start from square 1. For laughs, I tried to update a FC2 system also, and it did the same thing -- no upgrade, just right into install type, then disk druid if you keep going.

Is it possible to upgrade a CentOS3 or Fedora Core system directly to CentOS4?

Dan

M0nKeY
Posts: 3
Joined: 2005/01/18 07:55:25

Can't upgrade CentOS3.4 -> CentOS4?

Post by M0nKeY » 2005/03/20 22:50:37

Have you tried "linux upgradeany"

http://www.centos.org/docs/4/html/rhel-ig-x8664-multi-en-4/s1-upgrade-begin.html

My question is how the heck can we do a remote upgrade. CentOS3.4 -> CentOS4

Does not seem to be covered anywhere.

axon-obriend
Posts: 4
Joined: 2005/03/20 16:43:59
Location: Alexandria, VA
Contact:

Re: Can't upgrade CentOS3.4 -> CentOS4?

Post by axon-obriend » 2005/03/21 15:10:58

[quote]
M0nKeY wrote:
Have you tried "linux upgradeany"
[/quote]

Nope, sure didn't. That's just what I needed, though. Is this considered a bug? Is it looking for the RHEL tag in /etc/redhat-release? I'd think a reasonable person could assume that when upgraded CentOS that it would recognize "CentOS release 3.4 (final)" as an upgradable release.

[quote]
M0nKeY wrote:
My question is how the heck can we do a remote upgrade. CentOS3.4 -> CentOS4
[/quote]

I don't suppose

linux upgradeany vnc vncpassword="whatever"

would work... ?

Dan

axon-obriend
Posts: 4
Joined: 2005/03/20 16:43:59
Location: Alexandria, VA
Contact:

Re: CentOS3.4 -> CentOS4 - I2O issue

Post by axon-obriend » 2005/03/21 16:12:00

The system I'm upgrading has an Adaptec RAID controller that uses the i2o_block driver. For some reason, I suspect related to the transition to /devfs in the 2.6 kernel, it doesn't recogize the swap volume.

I did notice that under the 2.4 kernel, my drives were /dev/hda1 (swap), /dev/hda2 (/tmp), /dev/hdb1 (/boot), etc. Under the 2.6 kernel, they were /dev/i2o/hda2, /dev/i2o/hdb1, etc.

At the point in the CentOS 4 install where it tried to activate the swap, it gave an error message that it couldn't do it. I rebooted and tried changing the swap entry in /etc/fstab to /dev/i2o/hda2, but it gave the same error. Finally, I removed the swap file entry in /etc/fstab (the machine has 1G of memory, so I figured it should be OK for the install and I could manually add the swap entry back after the upgrade.

Other volumes were mounted with a LABEL= entry in /dev/fstab, so the appear to be unaffected by this change in 2.6 vs. 2.4 kernel.

Dan

axon-obriend
Posts: 4
Joined: 2005/03/20 16:43:59
Location: Alexandria, VA
Contact:

Re: CentOS3.4 -> CentOS4 - No Joy

Post by axon-obriend » 2005/03/21 16:50:41

OK

The upgrade *seemed* to proceed normally, until the first boot of the upgraded system. I've got a screen that says

Booting 'CentOS 4.0 2.6.9-5.0.3EL'

root (hd1,0)
Filesystem type unknown, partion type 0x82
kernel /vmlinuz-2.6.9-5.0.3EL ro root=LABEL=/ rhgb quiet

Error 17: Cannot mount selected partition

Press any key to continue...

My VGA text screen has a funny background, too (like some video memory corruption or a bizarre setting).

So much for upgrades... Trying a full install now that I've created a 1.0GHz paperweight.

madmalkav
Posts: 3
Joined: 2005/03/24 16:46:41

Re: Can't upgrade CentOS3.4 -> CentOS4?

Post by madmalkav » 2005/03/24 16:58:29

[quote]
I don't suppose

linux upgradeany vnc vncpassword="whatever"

would work... ?
[/quote]

Tell me how to get grub to do a linux upgradeany boot and I will try to do the install through vnc, but at this moment I was totally unable to do a grub entry that will boot linux upgradeany.

Post Reply

Return to “CentOS 4 - General Support”