RHES 4 RPM gfail on: "This Linux distribution is not supported"

General support questions including new installations
Post Reply
addady
Posts: 6
Joined: 2005/03/15 12:03:12

RHES 4 RPM gfail on: "This Linux distribution is not supported"

Post by addady » 2005/03/15 13:48:26

Hello,

I'm trying to install

HP System Management Homepage for Linux (x86)
http://h18023.www1.hp.com/support/files/server/us/download/22473.html
for Red Hat Enterprise Linux 4.
The installation fail on "This Linux distribution is not supported".
Can it be that the installation process in looking for some OS id like "Red Hat Enterprise Linux 4" and get instead some thing like: "Censos 4" it fail ?
If yes how can I workaround this problem?

Regards,
Addady

arrfab
Site Admin
Posts: 875
Joined: 2005/01/03 21:30:54
Location: /country/belgium
Contact:

Re: RHES 4 RPM gfail on: "This Linux distribution is not supported"

Post by arrfab » 2005/03/15 14:48:59

I'll have to install the same agents on a Compaq Proliant rebuild from Fedora Core 1 to CentOS 4 ...
For Fedora Core 1 , i had no such problems ... but it seems the new HP Rpms are looking the distro on wich you want to install the Agents ...
I've no real solution (because i haven't tested), but have you already tried to modify the /etc/redhat-release to simulate a Redhat Enterprise (actually, it contains CentOS release 4.0 (Final) ).
Hope this can help ... because i'll have the same problem in 2 weeks .... :-?
Let us know if this little workaround works for you .... Otherwise, it can be another thing that the agent is looking for .....

hughesjr
Site Admin
Posts: 251
Joined: 2004/12/05 01:51:26
Location: Corpus Christi, Texas, USA
Contact:

RHES 4 RPM gfail on: "This Linux distribution is not support

Post by hughesjr » 2005/03/16 10:46:53

right ... you can change your [b]/etc/redhat-release[/b] to say:

[b]Red Hat Enterprise Linux AS release 4 (Nahant)[/b]

Normally you can have both lines in there, by doing this:

[code]echo "Red Hat Enterprise Linux AS release 4 (Nahant)" >> /etc/redhat-release[/code]

Then your file will look like this:
[code][color=0000CC][root@x8664-build ~]# cat /etc/redhat-release[/color]
CentOS release 4.0 (Final)
Red Hat Enterprise Linux AS release 4 (Nahant)[/code]

addady
Posts: 6
Joined: 2005/03/15 12:03:12

Re: RHES 4 RPM gfail on: "This Linux distribution is not supported"

Post by addady » 2005/03/17 10:05:58

Thank it helped.
But I needed to delete the original line.

Addady

arrfab
Site Admin
Posts: 875
Joined: 2005/01/03 21:30:54
Location: /country/belgium
Contact:

Re: RHES 4 RPM gfail on: "This Linux distribution is not supported"

Post by arrfab » 2005/03/17 11:12:12

[quote]
addady wrote:
Thank it helped.
But I needed to delete the original line.
[/quote]
Which file did you need to delete ? /etc/redhat-release ?
PS : if a solution works for you, post your result to the forum ... Everybody who'll read the message will know the solution/workaround .... ;-)

Post Reply

Return to “CentOS 4 - General Support”