Page 1 of 1

[SOLVED] 404 error accessing buildsys repomd.xml

Posted: 2015/09/30 16:21:28
by deltadelta

Not sure if this is the right place for this, but it seemed to suit best. Our build system (for building x86_64 packages in a mock environment) has stopped working this afternoon with the following error:

Code: Select all

DEBUG: Executing /usr/sbin/mock-helper yum --installroot /var/lib/mock/centos-5-x86_64/root install buildsys-build autoconf automake libtool coreutils [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: groups. Please verify its path and try again
Could not find useradd in chroot, maybe the install failed?
DEBUG: Executing /usr/sbin/mock-helper umount /var/lib/mock/centos-5-x86_64/root/proc
DEBUG: Executing /usr/sbin/mock-helper umount /var/lib/mock/centos-5-x86_64/root/dev/pts
It looks like the buildsys directory has disappeared from and I can't find any announcements regarding this or where it has moved to. It used to be like this ... clnk&gl=uk

Could anyone tell me if there an issue with this at present or has a permanent change been made please?

Thanks for your time.

Re: 404 error accessing buildsys repomd.xml

Posted: 2015/09/30 19:22:31
by arrfab
Yes, it was also announced here : ... 21421.html
Normally we thought that nobody would be using old stuff on that server, but for your convenience, I've copied that buildsys directories to new nodes behind {buildlogs,dev}
Ideally create a bug report for this, instead of a forum post :-)

Re: [SOLVED] 404 error accessing buildsys repomd.xml

Posted: 2015/10/01 10:11:24
by deltadelta
Ah yeah, that announcement :oops:

Thanks for your help on this, and in future I'll go the bug route with this sort of thing instead.