Page 1 of 2

[SOLVED] Lost in CentOS

Posted: 2011/09/11 21:30:14
by DJay
I apologize in advance to all those I will annoy with this post, but I am lost...completely. I have a friend that has a Dell Poweredge 1750 with CentOS 5.2. I believe she only used it for a network drive, if that makes any sense. The router was rebooted and of course she lost the connection to the network drive. The problem is that she knows nothing about her network. An ex employee set it up and quit in a bad way. I need to get into this thing and try to connect this drive. I believe I have the user name and password since it's not erroring out anymore. When I input the username and password I get this prompt--sh-3.2$- I have no idea how to navigate in this thing. Once again I apologize, but not sure how to run your scripts for info. If anyone could help...please! Remember, I'm lost. So, please talk to me as if I were an idiot.

Sorry when I go into view/add configuration it shows 0) ONLIN A00-00, 1) ONLIN A00-01, 2) ONLIN A00-02,....6) Proc

Re: Lost in CentOS

Posted: 2011/09/11 21:57:06
by DJay
Maybe my above cry for help written too complicated since I don't know what I'm doing. Here's hopefully something easier.
Can anyone tell me how to reconnect a shared drive in CentOS after a router reset? I know the ip of the Dell Poweredge 1750 and I know what the ip of the share used to be. I really need help on this one.

[SOLVED] Lost in CentOS

Posted: 2011/09/12 01:31:11
by scottro
It's Sunday evening, at least on the east coast of the US, and folks are busy. I would first check fstab

less /etc/fstab

to see if the mount is shown there.

You might be able to mount it with

mount ///share_name mountpoint.

However, you may need root permissions for this. This may mean re-setting the root password, which you can do by rebooting in single user mode. And this is probably confusing you, another reason
you're not getting answers, these forums, while we welcome beginners, don't really answer the basic questions.

To reset root password

I've given you the syntax, but you might need to have credentials and so on--there are simply too many variables for someone to answer.
Figure out the way the share is shared--that is, is it through a Windows server, Linux server, or what, then google mount network share in linux, (adding windows share, linux share, and so on.)

As the server is CentOS, the share, if shared with Windows computers was probably mounted with samba. None of this is overly complex, but putting it together for someone who has no Linux experience probably requires more time than folks on the forum have to give you, whereas, someone with Linux experience who is on site can probably fix it in a few minutes.

If it were me. first I'd get on the CentOS server, I'd look in /etc/exports and /etc/samba/smb.conf to see if it was mounted in either place.

Also, what systems are accessing this share? Windows? OS X? Other Unix or Linux systems?

Re: Lost in CentOS

Posted: 2011/09/12 04:35:16
by DJay
I completely understand about the timing and appreciate your help.
They are all windows systems. 10 XP, 2 win 7's.

Re: Lost in CentOS

Posted: 2011/09/12 11:57:56
by scottro
In that case, it's almost certainly a samba mount. Look in /etc/samba/smb.conf to see what should be mounted, then you can try restarting samba. I'm not sure if 5.2 has smb and nmb. You have to look in /etc/init.d and see if there's a script called smb, nmb, and winbind or perhaps just one called samba. Regardless run

service restart

on all of them that are in there.

Again you will need root privilege.

Re: Lost in CentOS

Posted: 2011/09/12 13:31:19
by DJay
Thanks, you have given me a lot of info. I have tried what you have suggested. I was able to change the password successfully. But when I try run the paths you suggested I get permission denied. It seems to automatically boot into single user mode. Am I not in as root?
I try to use the su - username switch to change to root user. It asks for password I input and don't get an error. Still won't let me into /etc/samba/smb.conf. less/etc/fstab doesn't exist.

Re: Lost in CentOS

Posted: 2011/09/12 17:31:52
by scottro
The command you would type is

su -

It then asks for password. You put in root's password and your prompt should change from a $ to a #

If it's still not letting you into /etc/samba/smb.conf the person who left in a bad way probably did something bad. There should also be an /etc/fstab and that should be readable even if you are not root.

If it really doesn't exist, and if, as root, you can't get into /etc/samba to view smb.conf, there's a chance that the former employee broke something. Not sure what to tell you at this point save to get a Linux consultant.

Re: Lost in CentOS

Posted: 2011/09/12 17:47:30
by DJay
Thanks, got in as root user. /etc/samba doesn't exsist but this worked until router reset a couple days ago. The employee has been gone since february.
They only use for a network drive.
Thanks for your time and attention.

Re: Lost in CentOS

Posted: 2011/09/12 20:35:47
by scottro
Then I have no real idea how it was setup. Samba would have been the most likely if the clients are Windows, the only other thing I can think of off the top of my head is it being an iscsi server, (or possibly having a connection via fibre-channel to a san. I would google setting up samba to make something available to Windows clients. There are some fairly simple tutorials.

[SOLVED] Lost in CentOS

Posted: 2011/09/12 22:01:44
by DJay
Scottro thank you so much for you help. I solved my problem...kind of. Basically the data and settings in the server didn't change. So, I set the router to use an IP range that would include the server. After doing that the network drive was accessible. Problem solved.
I have been wanted to learn more about Linux. This wasn't the way I wanted learn, but hey. It is a very interesting OS.
Just for your info, because of all your help, Samba is on there. I did a "whereis samba" and it shows it down a long path.

Thanks again for taking the time to help the clueless. I learned a lot.