Page 1 of 1


Posted: 2011/06/21 02:00:19
by sohnaeo
Hi Forum,

We are installing the server with CentOS 5.6 and in the process of configuring iscsi.
The following command is executed to add a new volume to the system:
#iscsiadm -m node -T -I eql.eth2_0 -l -v automatic

After rebooting the system, it hangs while loading usb-storage module during the boot process.

If we boot the system with "nousb" parameter, the system would load normally. We suspected that iscsiadm command changes IRQ or something in the BIOS so we went on reflashing the BIOS with the current version (lastest). After that the system would boot normally. However, we encounter the same problem above after a volume is added by the iscsiadm command (above).

Below is what we found:

1. Ran the Iscsiadm command to load a volume.
2. CentOS hang while loading usb-storage module
3. Reboot the server with "nousb" as a kernel parameter and the server
boots successfully.
4. We inserted a CentOS DVD and tried to reinstall the OS, the installer
hang at "usb-storage" (before it gets to the first screen of the
installation process. Ie. prior to the language selection or partition
table screens). We also tried "linux rescue" command and it also hang
there (while loading usb-storage).
5. Reflash the BIOS of the server. It could boot normally. CentOS
installer/"linux rescue" do NOT hang.
6. Ran the Iscsiadm command to load the same volume again.
7. The same problem occurred.
8. Reflash the BIOS, everything works fine again.

We have 2 server Sun Fire X4170-M2 and the problem above occurs on both of them.

Any idea guys?




Posted: 2011/06/24 11:39:36
by pschaff
Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

sohnaeo wrote:
8. Reflash the BIOS, everything works fine again.
That ought to be a do-nothing if the BIOS is already at the latest version, unless there is some side effect like resetting the CMOS. Does a reboot or changing BIOS parameters work without re-flashing?