Oracle 11.2.0 instalation complete but can't run

Installation and support for Oracle DB on CentOS.
Post Reply
meryniki
Posts: 1
Joined: 2010/05/13 17:22:17

Oracle 11.2.0 instalation complete but can't run

Post by meryniki » 2010/05/13 17:41:46

I am new with CentOs. I've followed this instructions:
http://www.jameskoopmann.com/docs/Install_Oracle11gCentOS5.htm
and correctly installed Oracle 11g on a Centos 5.4 server.
But I can not run oracle database. I made /etc/init.d/oracle and configured it, but this just only starts the LISTENER (checked by "ps -fea | grep oracle")
Then i've tried to connect with "oracle" user by "sqlplus", and when it runs error "ORA-12514" comes up.
I would appreciate your help.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Oracle 11.2.0 instalation complete but can't run

Post by pschaff » 2010/05/13 21:03:05

Welcome to the CentOS fora. I'm not an Oracle user, so will just recommended the reading for new users:
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14274&forum=47]Readme First[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14408&forum=47]Installing Software[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14273&forum=47]Where to Find Answers[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=25128&forum=47]How to provide information about your system[/url]

Hopefully someone who has a clue about Oracle can answer your questions.

dmslvo
Posts: 1
Joined: 2010/05/16 02:39:46

Re: Oracle 11.2.0 instalation complete but can't run

Post by dmslvo » 2010/05/16 03:07:42

[quote]
meryniki wrote:
I am new with CentOs. I've followed this instructions:
http://www.jameskoopmann.com/docs/Install_Oracle11gCentOS5.htm
and correctly installed Oracle 11g on a Centos 5.4 server.
But I can not run oracle database. I made /etc/init.d/oracle and configured it, but this just only starts the LISTENER (checked by "ps -fea | grep oracle")
Then i've tried to connect with "oracle" user by "sqlplus", and when it runs error "ORA-12514" comes up.
I would appreciate your help.[/quote]

1) Did you run the Database Configuration Assistant after and create a database? The linked page specifically instructs to NOT create one during the Oracle install and to do so afterward. If you did not, log in as the oracle user and run

[code]dbca &[/code]

This starts the Database Configuration Assistant GUI and walks you through creating a database.

2) The ORA-12514 error usually indicates a problem with a file called "tnsnames.ora" which Oracle uses as an "address book" of database instances. The dbca utility may or may not automatically create/update this file with new database information; if not, a Google search for "configure tnsnames.ora" will give you what you need to create a correctly-formatted entry for your database.

Post Reply

Return to “CentOS 5 - Oracle Installation and Support”