error while installing oracle 11g in centos 5.3

Installation and support for Oracle DB on CentOS.
Post Reply
veeravicky
Posts: 3
Joined: 2010/03/08 04:25:15

error while installing oracle 11g in centos 5.3

Post by veeravicky » 2010/03/08 04:26:41

hi
i tried installing oracle 11g inn centos 5.3 and i got the following error.

./runInstaller
Starting Oracle Universal Installer...

Checking Temp space: must be greater than 80 MB. Actual 76430 MB Passed
Checking swap space: must be greater than 150 MB. Actual 6000 MB Passed
Checking monitor: must be configured to display at least 256 colors
>>> Could not execute auto check for display colors using command /usr/bin/xdpyinfo. Check if the DISPLAY variable is set. Failed >> Ignoring required pre-requisite failures. Continuing...
Preparing to launch Oracle Universal Installer from /tmp/OraInstall2010-03-07_12-09-48PM. Please wait ...[oracle@www database]$ Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Exception in thread "main" java.lang.NoClassDefFoundError
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:164)
at java.awt.Toolkit$2.run(Toolkit.java:821)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:80 4)
at com.jgoodies.looks.LookUtils.isLowResolution(Unkno wn Source)
at com.jgoodies.looks.LookUtils.(Unknown Source)
at com.jgoodies.looks.plastic.PlasticLookAndFeel.(PlasticLookAndFeel.java:122)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:242)
at javax.swing.SwingUtilities.loadSystemClass(SwingUt ilities.java:1783)
at javax.swing.UIManager.setLookAndFeel(UIManager.jav a:480)
at oracle.install.commons.util.Application.startup(Ap plication.java:758)
at oracle.install.commons.flow.FlowApplication.startu p(FlowApplication.java:164)
at oracle.install.commons.flow.FlowApplication.startu p(FlowApplication.java:181)
at oracle.install.commons.base.driver.common.Installe r.startup(Installer.java:265)
at oracle.install.ivw.db.driver.DBInstaller.startup(D BInstaller.java:114)
at oracle.install.ivw.db.driver.DBInstaller.main(DBIn staller.java:132)


pls help me solve this...i need detailed instructions since i am new to linux

yyagol
Posts: 1015
Joined: 2006/06/10 18:27:44
Location: 32 4′N 34 47′E
Contact:

error while installing oracle 11g in centos 5.3

Post by yyagol » 2010/03/08 05:55:03

Hi , and welcome to CentOS
first , you should move the post to the correct forum , there is a spacial
forum for Oracle here . as for the problem , just install xserver , and your problems will be gone
or use quit install , follow the documentation
http://download.oracle.com/docs/cd/E11882_01/install.112/e10840/toc.htm
http://www.oracle-base.com/articles/11g/OracleDB11gR1InstallationOnEnterpriseLinux4and5.php

User avatar
AlanBartlett
Forum Moderator
Posts: 9325
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: error while installing oracle 11g in centos 5.3

Post by AlanBartlett » 2010/03/08 15:15:25

Welcome to the [i]CentOS[/i] fora.

This thread has now been moved to the [i]CentOS 5 - Oracle Installation and Support[/i] forum.

Please follow [b]yyagol[/b]'s advice and if still experiencing difficulties, post again with full details of how the installation fails.

I should mention that usage of [i]CentOS 5.3[/i] is deprecated and, consequently, is not supported as [b]5.4[/b] has been the current release for quite some time. I would urge you to update your system [i]before[/i] reattempting the [i]Oracle[/i] installation. Please see the [url=http://wiki.centos.org/Manuals/ReleaseNotes/CentOS5.4]CentOS 5.4 release notes[/url] and follow the guidance at the bottom of Section #4, to avoid any possible [i]glibc[/i] complications.

babo
Posts: 72
Joined: 2008/02/29 14:37:31
Location: NJ, USA

Re: error while installing oracle 11g in centos 5.3

Post by babo » 2010/03/09 03:53:07

[code]
Xlib: connection to ":0.0" refused by server
[/code]

set the DISPLAY

mwentrcek
Posts: 1
Joined: 2010/03/25 10:41:01
Contact:

Re: error while installing oracle 11g in centos 5.3

Post by mwentrcek » 2010/03/25 10:54:07

make sure you have your 'oracle' user

READ THE INSTRUCTIONS to set up your groups and directories! This is not a plug an play program. Also make sure you set your parameters and kernel sizes.

If you are having issues will java errors it has to do with Xwindows (local or remote)

su - root
xhost + oracle

maybe 'xhost + localhost' or url

test 'xclock' under both

if it doesn't work make sure your have xlib-* installed

if you can't get 'xclock' to work you are probably missing xlib, xorg-x11-* as well

Good Luck,
Marcus Wentrcek

Post Reply

Return to “CentOS 5 - Oracle Installation and Support”