problem installing required package (glibc-devel-2.*)

Installation and support for Oracle DB on CentOS.
Post Reply
pograjc
Posts: 2
Joined: 2009/12/18 21:04:07

problem installing required package (glibc-devel-2.*)

Post by pograjc » 2009/12/19 01:44:32

I have CentOS 5.4 installed in VMware (downloaded already prepared appliance http://www.thoughtpolice.co.uk/vmware/#centos5.4)

I am trying to follow instructions:
[url=http://www.oracle-base.com/articles/11g/OracleDB11gR1InstallationOnEnterpriseLinux4and5.php]OracleDB11gR1InstallationOnEnterpriseLinux4and5.php[/url]

When i try to install glibc-devel-2.* i do get following error:

[b][root@localhost CentOS]# rpm -Uvh glibc-devel-2.*
error: Failed dependencies:
glibc = 2.5-42 is needed by glibc-devel-2.5-42.i386
glibc-headers = 2.5-42 is needed by glibc-devel-2.5-42.i386[/b]



I did try to install missing packages, but i do get message, that they already exist.


I do have installed (according to list of installed packages in Add/Remove sw):

glibc-2.5-42.el5_4.2.I686
glibc-common-2.5-42.el5_4.2.I386
glibc-headers-2.5-42.el5_4.2.I386


Is the problem, that i have I686 glibc instead I386?

If i try to install I386 it conflicts.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

problem installing required package (glibc-devel-2.*)

Post by pschaff » 2009/12/19 15:25:46

Welcome to the CentOS fora. You should be using yum to update or install. Using RPM to manually satisfy dependencies is labor-intensive and error-prone. Do the required reading, including [url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14408&forum=47]Installing Software[/url].

Before doing anything else, update as follows:
[code]
yum clean all
yum update glibc\*
yum update
shutdown -r now[/code]

pograjc
Posts: 2
Joined: 2009/12/18 21:04:07

Re: problem installing required package (glibc-devel-2.*)

Post by pograjc » 2009/12/20 17:55:15

I did find "yum clean all", but I was missing following steps.

Now it successfully installed glibc-devel-2.5-42.el5_4.2.i386.rpm. I hope this is the right one :)


Thank you. Yum seems to be much more advanced and smart.

User avatar
AlanBartlett
Forum Moderator
Posts: 9325
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: problem installing required package (glibc-devel-2.*)

Post by AlanBartlett » 2009/12/20 18:11:21

[quote]
Yum seems to be much more advanced and smart.
[/quote]
You have, in essence, summed up [i]yum[/i] -- it is an intelligent front-end to [i]rpm[/i]. :-)

Post Reply

Return to “CentOS 5 - Oracle Installation and Support”