Page 1 of 1

CentOS 5.5 x64 help installing php 5.3

Posted: 2011/02/15 07:41:35
by vivik
Hi guys,

I've been googling around and trying to find a solution to upgrading php 5.1 that comes with cent OS 5.5 to 5.3 or at least 5.2.12 and higher which i need to run phpmydirectory. I've tried the solution for the 32 bit CentOS to get 5.2.6 but in 64 bit i only get 5.2.10... Do you guys have any recommendations? (I want to have a 32 bit machine but it seems like the vps company we have only supplies 64 bit images, might change services later on but i'm stuck with them for now)

another question, i'm pretty new with linux and stuff, so i was just wondering, when i use rpm's signed by other people i don't know, is there a big risk? Is there anyway i can check the files installed is what i actually want to be installed?

Thanks

Re: CentOS 5.5 x64 help installing php 5.3

Posted: 2011/02/15 12:22:21
by TrevorH
The next update to Centos will take it to 5.6 and will include php 5.3. If you cannot wait that long, you could possibly grab the original Redhat source rpm from [url=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/php53-5.3.3-1.el5_6.1.src.rpm]here[/url] and rebuild it yourself.

CentOS 5.5 x64 help installing php 5.3

Posted: 2011/02/15 13:38:22
by pjwelsh
You can follow my easy directions from [url=http://pjwelsh.blogspot.com/2010/12/linux-rhelcentos-55-php-53-upgrade-made.html]HERE[/url] and have a support path.

Re: CentOS 5.5 x64 help installing php 5.3

Posted: 2011/02/16 04:41:54
by vivik
thanks for the info. I'll try rebuilding it, don't really know how to but http://wiki.centos.org/HowTos/RebuildSRPM should help :-)

if i have no success in rebuilding it, i'll probably just go for pjwelsh's link. thanks guys.