(semi solved) Help building 32bit packages on 64bit host (using mock) - missing some 32bit deps

Support for the other architectures (X86_64, IA-64, and PowerPC)
Post Reply
yossarianuk
Posts: 20
Joined: 2010/03/22 15:34:42

(semi solved) Help building 32bit packages on 64bit host (us

Post by yossarianuk » 2011/01/20 11:55:02

Hi.

I have successfully managed to build 32bit php-5.2.17 RPMs using mock on a x86_64 system.

I am having issues doing the same with php-extras due to missing 32bit dependencies.

i.e :-

setarch i386 mock -r centos-5-i386.cfg --arch=i686 installdeps php-extras-5.2.17-1.src.rpm


'libmcrypt-devel' 'php-devel = 5.2.17'
0:readline-devel-5.1-3.el5.i386
No Package Found for mhash-devel
No Package Found for freetds-devel
No Package Found for libtidy-devel
No Package Found for libmcrypt-devel

the above packages are missing 32bit packages for 64bit Centos in yum.

I have used mock to create 32bit RPM's - i.e :-

ls ../x86_RPMS/freetds/
build.log freetds-0.64-11.src.rpm freetds-devel-0.64-11.i686.rpm mockconfig.log
freetds-0.64-11.i686.rpm freetds-debuginfo-0.64-11.i686.rpm freetds-doc-0.64-11.i686.rpm root.log

But I cannot install them on the host system

rpm -ivh *.rpm

package libtidy-0.99.0-12.20070228.el5.centos.x86_64 (which is newer than libtidy-0.99.0-12.20070228.i686) is already installed

As mentioned I did managed to get the standard php-5.2.17 SRPM to create i686 rpms correctly - it seems that all the 32 bit deps I am missing are from the extras repo.

Anyone know how can get the deps installed ?

[Edit]

I found I have to add the [extras] repo to /etc/mock/centos-5-i386.cfg

I know have another issue - that is how to add a local yum repo to mock...

Anyone know ( i may just start a new thread)

Post Reply

Return to “CentOS 5 - X86_64,s390(x) and PowerPC Support”