[SOLVED] Linux Integration Services 2.1 on Hyper-V R2

Support for the other architectures (X86_64, IA-64, and PowerPC)
Post Reply
cbach
Posts: 7
Joined: 2011/01/11 14:06:58

[SOLVED] Linux Integration Services 2.1 on Hyper-V R2

Post by cbach » 2011/01/12 22:10:58

Hi,

I hope this is the right forum for this question.

I'm new to CentOS (or Linux for that matter) used to work with FreeBSD so please forgive any questions which seems stupid. :-)

I have read everything google gave me on this and all I could find in this forum on this matter. But no luck. :-(

This is the guide I found most usefull and detailed;
http://www.jcarle.com/2010/12/06/installing-centos-5-5-with-linux-integration-services-2-1-on-hyper-v-r2/

I have the latest CentOS 5.5 x64 with kernel 2.6.18-194.32.1.el5.
- Fully yum'ed.

And I followed the above mentioned guide to the letter. However I still get an error when trying to "make" the driver.

[quote]make[1]: Leaving directory `/usr/src/kernels/2.6.18-194.32.1.el5-x86_64' done.
Your system DOES NOT support the timesource driver[/quote]

I have read several places, including on the guide linked above, that I just needed to install adjtimex.

But still no dice.

Do I have to configure adjtimex or something? The guide only states that I need to "yum install adjtimex".

I hope someone on here could give me a hint, because I'm really out of ideas on what to do.

Best regards,
Christian

cbach
Posts: 7
Joined: 2011/01/11 14:06:58

[SOLVED] Linux Integration Services 2.1 on Hyper-V R2

Post by cbach » 2011/01/14 13:02:11

This is solved!

Just needed to read the whole guide again. Even with this error during make. It will make install fine. (just remember to PATH /sbin)

I hope this might at least save someone else som time.

Also note:
DKMS package
http://support.microsoft.com/kb/2387594
The above will enable you to kernel upgrade without any kernel panics

/Christian

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

[SOLVED] Linux Integration Services 2.1 on Hyper-V R2

Post by pschaff » 2011/01/14 18:19:06

Welcome to the CentOS fora. Reading [url=https://www.centos.org/modules/newbb/viewforum.php?forum=47]FAQ & Readme First[/url] is recommended for new users.

Thanks for reporting back. Marking this thread [SOLVED] for posterity.

For future reference, dkms is available in 3rd party repositories such as EPEL and [url=http://wiki.centos.org/Repositories/RPMForge]RPMforge repo[/url]. If configuring 3rd party repos reading [url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14408&forum=47]Installing Software[/url] and noting the warnings and advice about installing and configuring the [url=http://wiki.centos.org/PackageManagement/Yum/Priorities]yum priorities plugin[/url].

Post Reply

Return to “CentOS 5 - X86_64,s390(x) and PowerPC Support”