Canon LBP3010

Support for the other architectures (X86_64, IA-64, and PowerPC)
Post Reply
0xSIFE
Posts: 5
Joined: 2010/12/12 08:35:28
Contact:

Canon LBP3010

Post by 0xSIFE » 2010/12/12 08:46:13

I have AMD64 with CentOS 64bit 5.5, I am trying to install Canon LBP3010, I followed this instruction:

[code]
[root@localhost ]#wget http://files.canon-europe.com/files/soft39340/software/CAPT_Printer_Driver_for_Linux_V200_uk_EN.tar.gz
[root@localhost ]#tar -xzf CAPT_Printer_Driver_for_Linux_V200_uk_EN.tar.gz
[root@localhost ]#cd CAPT_Printer_Driver_for_Linux_V200_uk_EN/Driver/RPM
[root@localhost RPM]#rmp -ivh cndrvcups-capt-2.00-2.i386.rpm
[root@localhost RPM]#rpm -ivh cndrvcups-common-2.00-2.i386.rpm
[root@localhost RPM]#/usr/sbin/lpadmin -p LBP3010 -m CNCUPSLBP3050CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E
[root@localhost RPM]#/usr/sbin/ccpdadmin -p LBP3010 -o /dev/usb/lp0

CUPS_ConfigPath = /etc/cups/
LOG Path = None
UI Port = 59787

Entry Num : Spooler : Backend : FIFO path : Device Path : Status
----------------------------------------------------------------------------
[0] : LBP3010 : ccp : /var/ccpd/fifo0 : /dev/usb/lp0 : New!!
[root@localhost RPM]#/etc/init.d/ccpd restart
Shutting down /usr/sbin/ccpd: [FAILED]
.tarting /usr/sbin/ccpd: [ OK ]
[root@localhost RPM]# /etc/init.d/ccpd restart
Shutting down /usr/sbin/ccpd: [ OK ]
.tarting /usr/sbin/ccpd: [ OK ]
[root@localhost RPM]# /etc/init.d/cups restart
Stopping cups: [ OK ]
Starting cups: [ OK ]
[root@localhost RPM]# /etc/init.d/ccpd status
/usr/sbin/ccpd: 25921 25919
[root@localhost RPM]# captstatusui -P LBP3010 &
[1] 26000
[root@localhost RPM]# dmesg|tail
drivers/usb/class/usblp.c: usblp0: removed
usb 1-2: new high speed USB device using ehci_hcd and address 4
usb 1-2: configuration #1 chosen from 1 choice
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x04A9 pid 0x26DA
captmoncnab8[25908]: segfault at 00000000f7503acf rip 00000000f7503acf rsp 00000000f7501d60 error 14
usb 1-2: USB disconnect, address 4
drivers/usb/class/usblp.c: usblp0: removed
usb 1-2: new high speed USB device using ehci_hcd and address 5
usb 1-2: configuration #1 chosen from 1 choice
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 2 vid 0x04A9 pid 0x26DA
[/code]
Now I print it does not, did I miss some thing?

[Moderator edited to change the upper-case CODE into the required lower-case [i]code[/i] tags.]

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Canon LBP3010

Post by pschaff » 2010/12/12 13:49:51

Welcome to the CentOS fora. Reading [url=https://www.centos.org/modules/newbb/viewforum.php?forum=47]FAQ & Readme First[/url] is recommended for new users.

It is not obvious where you went wrong, but according to [url=http://www.openprinting.org/printer/Canon/Canon-LBP-3010]openprinting.org[/url] the version 2.0 driver does not work. They link to an earlier version.

0xSIFE
Posts: 5
Joined: 2010/12/12 08:35:28
Contact:

Re: Canon LBP3010

Post by 0xSIFE » 2010/12/16 16:32:13

I changed the driver to version 1.9, now I get the message below in attachment.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Canon LBP3010

Post by pschaff » 2010/12/16 18:36:58

The attachment function of the forum is permanently broken. Please post in-line, or if too long, at http://pastebin.centos.org/ .

0xSIFE
Posts: 5
Joined: 2010/12/12 08:35:28
Contact:

Re: Canon LBP3010

Post by 0xSIFE » 2010/12/19 13:11:23

[quote]pstocapt3 write error,32.[/quote]
I get it when I was printing a web page.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Canon LBP3010

Post by pschaff » 2010/12/21 14:14:02

I's suggest a google on the [url=http://www.google.com/search?q=pstocapt3+write+error+32&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&safe=active]error[/url], or perhaps tighten up the search a bit with [url=http://www.google.com/search?q=pstocapt3+write+error+32+centos+OR+rhel+OR+%22red+hat+enterprise+linux%22&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&safe=active]pstocapt3 write error 32 centos OR rhel OR "red hat enterprise linux"[/url].

0xSIFE
Posts: 5
Joined: 2010/12/12 08:35:28
Contact:

Re: Canon LBP3010

Post by 0xSIFE » 2010/12/22 19:39:43

I think its a bug in CentOS cups package accroding to this discussion: https://bugs.launchpad.net/ubuntu/+source/cups/+bug/286048?comments=all
After link some files like this:
[code]
ln -s /usr/lib/cups/filter/pstocapt /usr/lib64/cups/filter/pstocapt
ln -s /usr/lib/cups/filter/pstocapt2 /usr/lib64/cups/filter/pstocapt2
ln -s /usr/lib/cups/filter/pstocapt3 /usr/lib64/cups/filter/pstocapt3
ln -s /usr/lib/cups/backend/ccp /usr/lib64/cups/backend/ccp[/code]
logs show this:
[code]...
I [22/Dec/2010:12:41:36 -0500] [Job 20] Started filter /usr/lib/cups/filter/pstops (PID 5005)
I [22/Dec/2010:12:41:36 -0500] [Job 20] Started filter /usr/lib/cups/filter/pstocapt3 (PID 5006)
I [22/Dec/2010:12:41:36 -0500] [Job 20] Started backend /usr/lib/cups/backend/ccp (PID 5007)
E [22/Dec/2010:12:41:36 -0500] [Job 20] pstocapt3 write error,32.
E [22/Dec/2010:12:41:36 -0500] PID 5006 (/usr/lib/cups/filter/pstocapt3) stopped with status 1!
I [22/Dec/2010:12:41:36 -0500] Hint: Try setting the LogLevel to "debug" to find out more.
E [22/Dec/2010:12:41:36 -0500] [Job 20] Job stopped due to filter errors.
I [22/Dec/2010:12:51:13 -0500] [Job 21] Adding start banner page "none".
I [22/Dec/2010:12:51:13 -0500] [Job 21] Adding job file of type application/postscript.
I [22/Dec/2010:12:51:13 -0500] [Job 21] Adding end banner page "none".
I [22/Dec/2010:12:51:13 -0500] [Job 21] Queued on "LBP3010" by "root".
I [22/Dec/2010:12:51:13 -0500] [Job 21] Started filter /usr/lib/cups/filter/pstops (PID 5458)
I [22/Dec/2010:12:51:13 -0500] [Job 21] Started filter /usr/lib/cups/filter/pstocapt3 (PID 5459)
I [22/Dec/2010:12:51:13 -0500] [Job 21] Started backend /usr/lib/cups/backend/ccp (PID 5460)
E [22/Dec/2010:12:51:13 -0500] [Job 21] pstocapt3 write error,32.
E [22/Dec/2010:12:51:13 -0500] PID 5459 (/usr/lib/cups/filter/pstocapt3) stopped with status 1!
I [22/Dec/2010:12:51:13 -0500] Hint: Try setting the LogLevel to "debug" to find out more.
I [22/Dec/2010:12:51:13 -0500] [Job 21] Canceled by "root".
I [22/Dec/2010:13:41:05 -0500] Scheduler shutting down normally.
I [22/Dec/2010:13:41:05 -0500] Saving job cache file "/var/cache/cups/job.cache"...
I [22/Dec/2010:13:41:06 -0500] Listening to 127.0.0.1:631 (IPv4)
I [22/Dec/2010:13:41:06 -0500] Listening to /var/run/cups/cups.sock (Domain)
I [22/Dec/2010:13:41:06 -0500] Loaded configuration file "/etc/cups/cupsd.conf"
I [22/Dec/2010:13:41:06 -0500] Using default TempDir of /var/spool/cups/tmp...
I [22/Dec/2010:13:41:06 -0500] Configured for up to 100 clients.
I [22/Dec/2010:13:41:06 -0500] Allowing up to 100 client connections per host.
I [22/Dec/2010:13:41:06 -0500] Using policy "default" as the default!
I [22/Dec/2010:13:41:06 -0500] Full reload is required.
I [22/Dec/2010:13:41:06 -0500] Loaded MIME database from '/etc/cups': 35 types, 38 filters...
I [22/Dec/2010:13:41:06 -0500] Loading job cache file "/var/cache/cups/job.cache"...
I [22/Dec/2010:13:41:06 -0500] Full reload complete.
I [22/Dec/2010:13:41:06 -0500] Cleaning out old temporary files in "/var/spool/cups/tmp"...
I [22/Dec/2010:13:41:06 -0500] Listening to 127.0.0.1:631 on fd 4...
I [22/Dec/2010:13:41:06 -0500] Listening to /var/run/cups/cups.sock on fd 5...
I [22/Dec/2010:13:41:06 -0500] Resuming new connection processing...
I [22/Dec/2010:13:51:34 -0500] [Job 22] Adding start banner page "none".
I [22/Dec/2010:13:51:34 -0500] [Job 22] Adding job file of type application/postscript.
I [22/Dec/2010:13:51:34 -0500] [Job 22] Adding end banner page "none".
I [22/Dec/2010:13:51:34 -0500] [Job 22] Queued on "LBP3010" by "SIFE".
I [22/Dec/2010:13:51:34 -0500] [Job 22] Started filter /usr/lib/cups/filter/pstops (PID 7404)
I [22/Dec/2010:13:51:34 -0500] [Job 22] Started filter /usr/lib/cups/filter/pstocapt3 (PID 7405)
I [22/Dec/2010:13:51:34 -0500] [Job 22] Started backend /usr/lib/cups/backend/ccp (PID 7406)
I [22/Dec/2010:13:51:34 -0500] [Job 22] Canceled by "root".
I [22/Dec/2010:14:06:22 -0500] Scheduler shutting down normally.
I [22/Dec/2010:14:06:22 -0500] Saving job cache file "/var/cache/cups/job.cache"...
I [22/Dec/2010:14:06:22 -0500] Listening to 127.0.0.1:631 (IPv4)
I [22/Dec/2010:14:06:22 -0500] Listening to /var/run/cups/cups.sock (Domain)
I [22/Dec/2010:14:06:22 -0500] Loaded configuration file "/etc/cups/cupsd.conf"
I [22/Dec/2010:14:06:22 -0500] Using default TempDir of /var/spool/cups/tmp...
I [22/Dec/2010:14:06:22 -0500] Configured for up to 100 clients.
I [22/Dec/2010:14:06:22 -0500] Allowing up to 100 client connections per host.
I [22/Dec/2010:14:06:22 -0500] Using policy "default" as the default!
I [22/Dec/2010:14:06:22 -0500] Full reload is required.
I [22/Dec/2010:14:06:22 -0500] Loaded MIME database from '/etc/cups': 35 types, 38 filters...
I [22/Dec/2010:14:06:22 -0500] Loading job cache file "/var/cache/cups/job.cache"...
I [22/Dec/2010:14:06:22 -0500] Full reload complete.
I [22/Dec/2010:14:06:22 -0500] Cleaning out old temporary files in "/var/spool/cups/tmp"...
I [22/Dec/2010:14:06:22 -0500] Listening to 127.0.0.1:631 on fd 4...
I [22/Dec/2010:14:06:22 -0500] Listening to /var/run/cups/cups.sock on fd 5...
I [22/Dec/2010:14:06:22 -0500] Resuming new connection processing...
I [22/Dec/2010:14:07:12 -0500] [Job 23] Adding start banner page "none".
I [22/Dec/2010:14:07:12 -0500] [Job 23] Adding job file of type application/postscript.
I [22/Dec/2010:14:07:12 -0500] [Job 23] Adding end banner page "none".
I [22/Dec/2010:14:07:12 -0500] [Job 23] Queued on "LBP3010" by "SIFE".
I [22/Dec/2010:14:07:12 -0500] [Job 23] Started filter /usr/lib/cups/filter/pstops (PID 7805)
I [22/Dec/2010:14:07:12 -0500] [Job 23] Started filter /usr/lib/cups/filter/pstocapt3 (PID 7806)
I [22/Dec/2010:14:07:12 -0500] [Job 23] Started backend /usr/lib/cups/backend/ccp (PID 7807)
I [22/Dec/2010:14:07:12 -0500] [Job 23] Completed successfully.[/code]

User avatar
AlanBartlett
Forum Moderator
Posts: 9324
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: Canon LBP3010

Post by AlanBartlett » 2010/12/23 00:47:36

[quote]
I think its a bug in CentOS cups package accroding to this discussion: https://bugs.launchpad.net/ubuntu/+source/cups/+bug/286048?comments=all
[/quote]
I fail to understand your logic in assuming there is a bug in the [i]cups[/i] package of [i]CentOS[/i] just because there was a problem with [i]Ubuntu[/i] in October 2008. :roll:

Post Reply

Return to “CentOS 5 - X86_64,s390(x) and PowerPC Support”