Page 1 of 1

Volume Group showing old files

Posted: 2010/09/15 03:05:37
by jrobbins
I had a system melt-down this morning and I needed to try and rescue some files off the system before I did a reinstall. The system has an nVidia raid card installed and I am running two disks mirrored. From what I gather, the main partition is a Volume Group with with two logical volumes / and swap. I booted off a LiveCD to rescue the files. The LiveCD found and mounted the Volume Group but when I investigated my files on the volume they were from 6 months ago. I had made changes as recently as the previous day. It was almost as if it was showing a snap shot from when the system was initially configured.

Does anyone have any idea or directions to point me where I can find out what happened to my files? The server is a colocated server, so I was sort of forced into the configuration, thus I really don't know much about LVM and VolumeGroups. I apologize for the stuttered request for help, I am not sure what happened, so I am having some problems articulating exactly what the issue is.

If I can answer any questions to help ascertain the issue let me know, thanks in advance,

Volume Group showing old files

Posted: 2010/09/15 15:23:35
by pschaff
Welcome to the CentOS fora. The following reading is recommended for new users:
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14274&forum=47]Readme First[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14408&forum=47]Installing Software[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14273&forum=47]Where to Find Answers[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=25128&forum=47]How to provide information about your system[/url]

My best guess is that you have had a degraded RAID for quite some time, and are seeing the failed RAID member, rather than the up to date one. Please show the results from [b]./getinfo.sh disk[/b] from the 4th link above.