Page 1 of 1

[SOLVED] NMI received unknown reason 2c (and 3c)

Posted: 2010/09/14 17:44:09
by PBAsh
Hello all,

I wonder if you would be able to help me with an issue we are seeing on a couple of our servers. We have two IBM x3550 m2 servers with eight NIC ports (4 Broadcom NetXtreme II and 4 x Intel Pro/1000).

We have recently installed CentOS 5.5, kernel version 2.6.18-194.el5 and we get the following error in the messages log file when plugging in the network cable.

Uhhuh. NMI received unknown reason 2c (or 3c)
Do you have a strange power saving mode enabled?
Dazed and Confused, but trying to continue.

This causes the servers to reboot.

One of these servers was recently running with only the four broadcom devices and an older version of CentOS 5.4, kernel version 2.6.18-164.el5 and I don't believe we had these problems. We recently added the Intel NICs and upgraded to 5.5.

I'm planning to boot off an older kernel tomorrow to see if the problem goes away.

I can get the server to crash at will just be plugging the cable in one of the broadcom ports maybe once or twice. Where as I can happily plug and unplug in the Intel ports.

Thanks for any help provided.


[SOLVED] NMI received unknown reason 2c (and 3c)

Posted: 2010/09/14 21:13:21
by AlanBartlett
Welcome to the [i]CentOS[/i] fora.

The recommended reading for all new members is the [url=]FAQ & Readme First[/url].

The first thing I would like you to do is to fully update one of the servers. I assume you are able to use one of the NICs without promoting a crash? I would recommend that you have the Ethernet cable connected before booting up the system. Once you have the system updated, then please reboot it -- so that it is running the current version of the kernel, [i]2.6.18-194.11.3.el5[/i].

If you are still experiencing the NMI issue with a fully updated system, please provide access to the output produced by executing --

[b]./ network[/b]
-- as detailed in [url=]How to Provide Information About Your System[/url].

Re: NMI received unknown reason 2c (and 3c)

Posted: 2010/09/15 18:41:26
by PBAsh
Thanks for the help Alan.

I should have said that I tried updating to no avail. Sorry.

It turned out to be a problem with the hardware. Apparently a known issue with the server and the broadcom on-board expansion card.

For anyone reading this with an IBM x3550 m2 crashing when you plug a network cable in port 3 or 4. You need to ask IBM to send you the part upgrade and from what I can make out it is just a clip of some description.

Re: [SOLVED] NMI received unknown reason 2c (and 3c)

Posted: 2010/09/15 22:21:24
by AlanBartlett
Thank you for reporting back.

For posterity, this thread is marked [SOLVED].