Page 1 of 2

Freenx issue

Posted: 2010/06/22 17:03:31
by sms552
quick background... i have a production linux server that was working... then freenx stopped working for no reason.. im getting this error .
NX> 148 Server capacity: not reached for user: ssmith
NX> 105 startsession --link="lan" --backingstore="1" --encryption="1" -- cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="hart" --type="unix-gnome" --geometry="1024x768" --client="winnt" --keyboard="pc102/en_US" --screeninfo="1024x768x32+render"

NX> 1000 NXNODE - Version 3.2.0-73 OS (GPL, using backend: not detected)
NX> 700 Session id: server-1001- 1D01EE9497BC1D313F8118E5155FA7B4
NX> 705 Session display: 1001
NX> 703 Session type: unix-gnome
NX> 701 Proxy cookie: e4eab1b78fd6715ff787ccc63f83955b
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: e4eab1b78fd6715ff787ccc63f83955b
NX> 704 Session cache: unix-gnome
NX> 707 SSL tunneling: 1
NX> 1009 Session status: starting
NX> 105 NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set SESSION_LOG_CLEAN=0 in node.conf and investigate "/home/ssmith/.nx/F-C- server-1001-1D01EE9497BC1D313F8118E5155FA7B4/session". You might also want to try: ssh -X myserver; /usr/bin/nxnode --agent to test the basic functionality. Session log follows:
NX> 1006 Session status: closed
NX> 1009 Session status: starting
NX> 1001 Bye.
/usr/bin/nxserver: line 1531: 7069 Terminated sleep $AGENT_STARTUP_TIMEOUT
Can't open /var/lib/nxserver/db/running/sessionId{1D01EE9497BC1D313F8118E5155FA7B4}: No such file or directory.
mv: cannot stat `/var/lib/nxserver/db/running/sessionId{1D01EE9497BC1D313F8118E5155FA7B4}': No such file or directory
NX> 280 Exiting on signal: 15
i have an ldap server for authentication and i get this error when i try to use one of the ldap users. root works. i can ssh in with the ldap users and that works as well. i have another server with the exact configuration that is working with the ldap and i have compared conf files and everything seems to check out but it wont work. im at a loss about what to do and the interwebs have been absolutely no help. also i checked the part in node.conf to work with pam authentication. any help would be amazing...
OS type.. centos 5.5 64bit

Freenx issue

Posted: 2010/06/22 17:25:27
by toracat
Can you think of anything that might have happened to the system when "freenx stopped working" ? Some package update, configuration change, etc...

Is your sshd set up with PasswordAuthentication [b]yes[/b] ? If you are allowing password authentication, you can completely skip Section 2 Key-based authentication of http://wiki.centos.org/HowTos/FreeNX and see if nx works that way.

Have you tried the suggestion in the message (To troubleshoot set SESSION_LOG_CLEAN=0 in node.conf and investigate ...) ?

Re: Freenx issue

Posted: 2010/06/22 18:03:18
by sms552
i ran an update the day before and everything worked afterwards.. i just tried to enable logging and it doesnt seem to be working.. i enabled logging in node.conf and checked the directory under my home directory and there is no file to match the one from the error log. i tried several times to log in and then checked the folder and there was no file matching.

Re: Freenx issue

Posted: 2010/06/22 18:46:32
by toracat
Which version of nx are you running? Please show us the output from rpm -q nx freenx .

Re: Freenx issue

Posted: 2010/06/22 18:51:51
by sms552
nx-3.4.0-3.el5.centos
freenx-0.7.3-3.el5.centos

Re: Freenx issue

Posted: 2010/06/22 19:18:30
by toracat
OK, that's the latest official CentOS version.

Getting logging to work would really help. Could you try once again? You indicated logging was enabled. Did you also disable "cleaning" by [i]SESSION_LOG_CLEAN=0[/i] ?

Re: Freenx issue

Posted: 2010/06/22 19:33:08
by sms552
i went back in and checked it again and it is set to log,... there are old log files in there but nothing new..

Re: Freenx issue

Posted: 2010/06/22 20:00:17
by sms552
just ran nxloadconfig --check...



[root@server nxserver]# nxloadconfig --check
Warning: Could not find nxdesktop in /usr/bin. RDP sessions won't work.
Warning: Could not find nxviewer in /usr/bin. VNC sessions won't work.
Warning: Invalid value "APPLICATION_LIBRARY_PRELOAD=/usr/lib/libX11.so.6.2:/usr/lib/libXext.so.6.4:/usr/lib/libXcomp.so.2:/usr/lib/libXcompext.so:/usr/lib/libXrender.so.1.2". /usr/lib/libX11.so.6.2 could not be found. Users will not be able to run a single application in non-rootless mode.
Warning: Invalid value "DEFAULT_X_SESSION=/etc/X11/xdm/Xsession"
Users might not be able to request a default X session.
Warning: Invalid value "COMMAND_START_CDE=cdwm"
Users will not be able to request a CDE session.
Warning: Invalid value "COMMAND_SMBMOUNT=smbmount". You'll not be able to use SAMBA.
Warning: Invalid value "COMMAND_SMBUMOUNT=smbumount". You'll not be able to use SAMBA.
Error: Could not find 1.5.0 or 2.[01].0 or 3.[01].0 version string in nxagent. NX 1.5.0 or 2.[01].0 or 3.[012].0 backend is needed for this version of FreeNX.

Warnings occured during config check.
To enable these features please correct the configuration file.



from a little research i found out i dont seem to have nxlib installed... how would i go about doing that..

Re: Freenx issue

Posted: 2010/06/22 20:08:25
by toracat
With the "nxloadconfig --check" command, I get the same output as yours on my 2 different machines.

Re: Freenx issue

Posted: 2010/06/22 20:12:08
by sms552
ok well i thought i was on the right track...