Page 1 of 1

[SOLVED] invalid magic number centos5, xen

Posted: 2010/04/10 12:46:07
by tompalaz
I've bought a book about Xen, in the book they use CentOS, so I thought I should do the same.
However, I have a Ubuntuserver running (just a subversion server) that I'd like to use time to time.
So I try to dualboot my computer with ubuntu-server(9.10) and CentOS 5 64bit.
During the install of CentOS I chosed to install without a bootloader, I thought that Ubuntu's grub2 could handle this.
CentOS is found by grub but when I try to boot I get "invalid magic number"

I should mension that I chosed the virtualisation package when I installed.
When I have googled this this seems to be related to xen and the modified kernel.

Is there a way to solve this or is the modified xenkernel not compatible with grub2?

edit: managed to chroot in to the install and upgrade all the packages, though there's no difference, it won't boot
just produce the "invalid magic number" message.


[SOLVED] invalid magic number centos5, xen

Posted: 2010/04/10 13:24:19
by pschaff
Welcome to the CentOS fora. The following reading is recommended for new users:
[url=]Readme First[/url]
[url=]Installing Software[/url]
[url=]Where to Find Answers[/url]
[url=]How to provide information about your system[/url]

As far as your GRUB issues, on dual/multi-boot with Ubuntu or Fedora I generally install the CentOS GRUB to the boot partition, rather than the MBR (using the advanced option in the installer) and chainload CentOS grub. This also make kernel updates much less painful. A forum search on "grub ubuntu" will turn up posts such as

You may also want to read how to [url=]Re-Install GRUB[/url] or in this case, install.

Re: invalid magic number centos5, xen

Posted: 2010/04/10 19:23:02
by tompalaz
Thank you.

This is how I'm going to do, I have reinstalled everything, I've removed the ubuntu-server and I'm going to virtualize it now instead.
Problem now is only that I can't get xen to install ubuntu as domU, it won't take either the cdrom or the servers I type.

well, thread can be marked as solved.

Re: invalid magic number centos5, xen

Posted: 2010/04/11 00:02:18
by pschaff
You're welcome. More like worked around than solved, but so marked. :-)