PHP MySQL library version

Support for webhosts that use CentOS
User avatar
TrevorH
Forum Moderator
Posts: 27438
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: PHP MySQL library version

Post by TrevorH » 2011/10/03 15:44:53

[quote]
mysqlclient15-5.0.90.1.el5.art.i386
[/quote]

This one appears to be older than the other mysql\* packages

khaled_jamal
Posts: 12
Joined: 2011/09/30 12:59:53

Re: PHP MySQL library version

Post by khaled_jamal » 2011/10/03 15:47:37

yeah but how can i update it so it match the others ?

User avatar
TrevorH
Forum Moderator
Posts: 27438
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: PHP MySQL library version

Post by TrevorH » 2011/10/03 16:17:41

There appears to be a mysqlclient16 package there but no mysqlclient15 of the correct release. Looks like they may have a bug in that lot.

This is one good reason for sticking to the CentOS supplied versions of everything unless you explicitly require some new feature in the newer versions. The CentOS supplied versions are php 5.1.6 or php53 5.3.3 and mysql 5.0.77.

Do you actually [u]need[/u] the newer versions?

khaled_jamal
Posts: 12
Joined: 2011/09/30 12:59:53

Re: PHP MySQL library version

Post by khaled_jamal » 2011/10/03 16:28:35

the reason that i did upgrade my php for was wordpress. so i think yes i need the update.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: PHP MySQL library version

Post by pschaff » 2011/10/03 17:07:30

Your options appear to be:
1. Downgrade all the Atomic mysql packages to 5.1.57 versions and install mysqlclient16-5.1.57-1.el5.art until they produce the missing 5.1.59 package.
2. Find another repo that does have a consistent package set of the versions you require.

User avatar
TrevorH
Forum Moderator
Posts: 27438
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: PHP MySQL library version

Post by TrevorH » 2011/10/03 17:46:39

Looks to me like you could just use the php53 packages supplied by CentOS and also the ordinary mysql packages

[quote]
To run WordPress your host just needs a couple of things:

PHP version 5.2.4 or greater
MySQL version 5.0 or great
[/quote]

khaled_jamal
Posts: 12
Joined: 2011/09/30 12:59:53

Re: PHP MySQL library version

Post by khaled_jamal » 2011/10/03 22:33:19

well yeah i am not out after having the latest version. how can i downgrade to 5.1.57 is there any guide i can follow ?

khaled_jamal
Posts: 12
Joined: 2011/09/30 12:59:53

Re: PHP MySQL library version

Post by khaled_jamal » 2011/10/04 16:34:00

can i remove the repo i added (atomic ) and make new fresh install for php and mysql using this repo http://www.jasonlitka.com/yum-repository/ ?

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: PHP MySQL library version

Post by pschaff » 2011/10/05 15:38:11

It seems like you might be able to use either the CentOS php53 or the Jason Litka packages sets, after removing all the Atomic packages and disabling that repo.

I see[code]# yum --disablerepo \* --enablerepo utterramblings list php-5.2\* mysql\*
Loaded plugins: allowdowngrade, downloadonly, fastestmirror, priorities
...
Available Packages
mysql.x86_64 5.1.58-jason.1 utterramblings
mysql-bench.x86_64 5.1.58-jason.1 utterramblings
mysql-cluster.x86_64 5.0.91-jason.2 utterramblings
mysql-devel.x86_64 5.1.58-jason.1 utterramblings
mysql-server.x86_64 5.1.58-jason.1 utterramblings
mysql-test.x86_64 5.1.58-jason.1 utterramblings
mysqlclient15.x86_64 5.0.91-1.jason.1 utterramblings
mysqlclient15-devel.x86_64 5.0.91-1.jason.1 utterramblings
php.x86_64 5.2.17-jason.2 utterramblings[/code]
I don't know if the mysqlclient15-5.0.91-1.jason.1 is going to be a problem.

khaled_jamal
Posts: 12
Joined: 2011/09/30 12:59:53

Re: PHP MySQL library version

Post by khaled_jamal » 2011/10/05 18:17:50

aha :/ is it worth to give it a try ?

Post Reply

Return to “CentOS 5 - Webhosting Support”