setting up multiple domains on a local network

Support for webhosts that use CentOS
Post Reply
Drunk_N_Japan
Posts: 5
Joined: 2007/09/24 15:28:38
Location: Rocket City
Contact:

setting up multiple domains on a local network

Post by Drunk_N_Japan » 2008/01/28 13:11:26

I have been trying to set up a twst server on our local domain and I am having trouble setting it up for multiple domains. I have tried virtual host and editing the ect/hosts file but I am not confident that I am doing this right. I have read the virtual hosts pages at apache dot org and I have searched many different forums looking for an answer to this question. Any help would be appreciated.

Please let me know if you need me to post any thing so that I can clean it up.

Would adding a hosts file to my PCs and directing the site example.com w/out the www. to the internal ip 192.168.1.3 work, and if so how can I do this for the MACs that I have in the office?

Thanks for the advice.

trogers
Posts: 1
Joined: 2008/01/28 23:03:07
Contact:

Re: setting up multiple domains on a local network

Post by trogers » 2008/01/28 23:47:36

You need to setup DNS for the domains that your web server is going to host.

I am assuming these virtual domains are not TLDs (com,net etc...) but rather private test domains, (dom, xom, etc..) at this point, and only going to be viewable on the local network, which is listed in your post as 192.168.1.x

This being the case, do you have BIND running?

A google on BIND will give you a wealth of info related to installation & configuration.

IF this is the directions you are going and want more info let me know. I will be glad to share some methods I used to configure virtual domains and dns for use on my LAN.

Drunk_N_Japan
Posts: 5
Joined: 2007/09/24 15:28:38
Location: Rocket City
Contact:

Re: setting up multiple domains on a local network

Post by Drunk_N_Japan » 2008/01/30 19:57:11

[quote]
trogers wrote:
You need to setup DNS for the domains that your web server is going to host.

I am assuming these virtual domains are not TLDs (com,net etc...) but rather private test domains, (dom, xom, etc..) at this point, and only going to be viewable on the local network, which is listed in your post as 192.168.1.x

This being the case, do you have BIND running?

A google on BIND will give you a wealth of info related to installation & configuration.

IF this is the directions you are going and want more info let me know. I will be glad to share some methods I used to configure virtual domains and dns for use on my LAN.[/quote]

That is the road sign I have been looking for on this dark and BINDing road. lol.
I spent yesterday reading up on bind and I am ready to figure this stuff out.
I have setup my 127.0.0.1 on my server to the correct domains I want to use but I haven't quite figured out the bind part yet so that the other computers in my network can see the sites but the outside world cannot.

Any and all help is appreciated.

Post Reply

Return to “CentOS 5 - Webhosting Support”