simple mail server! "relay access denied" OMG!

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
Posts: 2
Joined: 2015/05/07 04:15:03

simple mail server! "relay access denied" OMG!

Post by waterlink » 2015/05/07 04:43:02

Hey i have literally been at this for months. I have tried all differant OS's as well as reading many forums to try and fix this.
im trying to set up an vps smtp server so i can send emails to my list from a bulk mailer on my home computer. i have followed multiple how to guides on setting up postfix,dovecot, sasl auth on various OS's but get the same problem everytime..

I can send a mail to a through localhost know worries but when i "telnet 25" i get relay access denied. also if i put the smtp details into my client mailer it just doesn't recognize them.

Here are some details into it

mail from: root
rcpt to:
554 5.7.1 <>: relay access denied
inet_protocols = ipv4
home_mailbox = Maildir/
smtpd_banner = $myhostname ESMTP $mail_name
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
mynetworks = [::ffff:]/104 [::1]/128
smtpd_sasl_auth_enable = yes
smtpd_sasl_type = cyrus
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_path = smtpd
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

May 7 08:16:08 mail postfix/smtpd[26620]: connect from[]
May 7 08:16:58 mail postfix/smtpd[26620]: NOQUEUE: reject: RCPT from[]: 554 5.7.1 <>: Relay access denied; from=<root> to=<> proto=ESMTP helo=<>
May 7 08:17:00 mail dovecot: pop3-login: Aborted login: user=<backup@OEMFACTORYJERSEYS.COM>, method=PLAIN, rip=::ffff:, lip=::ffff:
May 7 08:17:10 mail postfix/smtpd[26620]: disconnect from[]

Any ideas are truly appreciated :D

Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: simple mail server! "relay access denied" OMG!

Post by gerald_clark » 2015/05/07 12:50:10

Many ISPs block port 25 for home accounts.
Business use is a violation of your terms of use agreement.
They do not want people spamming from home accounts.

Posts: 2
Joined: 2015/05/07 04:15:03

Re: simple mail server! "relay access denied" OMG!

Post by waterlink » 2015/05/07 14:43:48

No it's not a blocked port, I checked that.. I think it's more an authentication issue. Today I allowed my server ip into $mynetworks and it worked so it must be sassl auth. I'm so over it lol

Post Reply

Return to “CentOS 5 - Server Support”