Http Thinks / Filesystem is Read Only

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
joer
Posts: 1
Joined: 2013/09/27 21:22:19

Http Thinks / Filesystem is Read Only

Post by joer » 2013/09/27 21:40:33

I am running CentOS release 5.9 and httpd version httpd-2.2.3-81. Httpd stopped running and when
I tried to restart it the following message appeared:

# /sbin/service httpd start
Starting httpd: (30)Read-only file system: httpd: could not open error log file /etc/httpd/logs/error_log.
Unable to open logs

That file is on the root file system (/). Running mount says the filesystem is read-write. I was also able to
create a file in /.

I tried

mount -o remount,rw /

which didn't help.

I also tried a reboot which did not help.

Earlier in the day a yum update of httpd (along with gdm) failed (as part of a general yum update) with
the following errors:
Running Transaction
Updating : httpd 1/4
Error unpacking rpm package httpd-2.2.3-82.el5.centos.i386
error: unpacking of archive failed on file /var/log/httpd: cpio: chown
Updating : gdm 2/4
Error unpacking rpm package 1:gdm-2.16.0-59.el5.centos.1.i386
error: unpacking of archive failed on file /var/log/gdm: cpio: chown

Failed:
gdm.i386 1:2.16.0-59.el5.centos.1 httpd.i386 0:2.2.3-82.el5.centos

I don't know if the httpd update failure is related (it seems unlikely). I was getting round to looking into this
problem. The rest of the update ran properly.

This is a virtual server running under VMWare. Co-workers are looking into VMWare issues.

Is there anything else that I can do or look for on the Linux side of things. I've never encountered a single
program filesystem problem before and searching did not turn up this problem.

Thank you.

User avatar
TrevorH
Forum Moderator
Posts: 29112
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Http Thinks / Filesystem is Read Only

Post by TrevorH » 2013/09/27 22:42:09

In all cases that I've seen where the system has reported problems with a readonly filesystem, it has really been readonly, caused usually by I/O errors on the underlying disk. Try checking in /var/log/messages for errors on the disk.

/etc/httpd/logs is a symlink to ../../var/log/httpd so is you /var a separate filesystem and did you check that?

Post Reply

Return to “CentOS 5 - Server Support”