service smb start fail after installing samba3x

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
C3s4r
Posts: 2
Joined: 2013/09/20 20:45:59

service smb start fail after installing samba3x

Post by C3s4r » 2013/09/20 20:59:36

Hello community,

I was recycling an old AMD PC as a file server and installed centos 5.9 64 (I tried to install Centos 6 but it didn't detect the disk!). I was configuring samba but with no luck, then I read that samba version 3.0.33 was too old for w7 and to install samba3x. so I just remove samba [i]yum remove samba[/i] and then install samba3x [i]yum install samba3x[/i]. After that [i]service smb start[/i] fails and I don't know why as the are no errors in /var/log/messages.

If anybody could point me in the right direction I will be really thankful.

Regards,

Cesar.

C3s4r
Posts: 2
Joined: 2013/09/20 20:45:59

Re: service smb start fail after installing samba3x

Post by C3s4r » 2013/09/20 21:14:58

It seems it was my previous smb.conf

[root@samurai samba]# mv smb.conf smb.conf.bak
[root@samurai samba]# cp smb.conf.original smb.conf
[root@samurai samba]# service smb start
Starting SMB services: [ OK ]

And I don't know why as it pass testparm...

[root@samurai samba]# testparm smb.conf.bak
Load smb config files from smb.conf.bak
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[multimedia]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

jstaffon
Posts: 1
Joined: 2014/10/26 20:30:20

Re: service smb start fail after installing samba3x

Post by jstaffon » 2014/10/26 20:32:30

Did you ever get this resolved? I am having the same exact problems. I'm running CentOS 6.5. Nmbd starts just fine but the smbd doesn't.

Post Reply

Return to “CentOS 5 - Server Support”