[SOLVED] DHCP installation PROBLEM

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
hannibal007
Posts: 9
Joined: 2013/09/01 23:29:28

[SOLVED] DHCP installation PROBLEM

Post by hannibal007 » 2013/09/02 00:53:55

Hi everybody,

i would like to install DHCP server but i have problem when starting dhcpd with service command :


well, after installing dhcp with ]#yum install dhcp; this is the /etc/dhcpd.conf file configuration :


[img align=right]http://i.imgur.com/kyQAp65.jpg[/img]

this is the result of /usr/sbin/dhcpd : it indicates an error on line 7 semi colums expected




i didn't now what to do exactly ??????[img align=right]http://i.imgur.com/KE4B28v.jpg[/img]

HenrykD
Posts: 73
Joined: 2011/01/14 06:09:52
Location: Poland

Re: DHCP installation PROBLEM

Post by HenrykD » 2013/09/02 05:36:29

Change the configuration file by changing this line:

ddns-update-style ad-hoc;

hannibal007
Posts: 9
Joined: 2013/09/01 23:29:28

Re: DHCP installation PROBLEM

Post by hannibal007 » 2013/09/02 10:17:06

The ad-hoc option dosen't work !!(i've made research on google and the ad-hoc option is used rarely) even the interim option too !!!!!!!!!!!!!!!!!!!

[img align=right]http://i.imgur.com/pHOhDPw.jpg[/img]

Acoording to the documentation, all thing seems to be ok but it doesen't work, Is their any additional configuration must be done ??????

User avatar
TrevorH
Forum Moderator
Posts: 29145
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: DHCP installation PROBLEM

Post by TrevorH » 2013/09/02 10:31:10

You have a great long line of "-" signs immediately prior to the ddns-update-style line and those are not commented so it's trying to interpret them as a configuration directive.

hannibal007
Posts: 9
Joined: 2013/09/01 23:29:28

Re: DHCP installation PROBLEM

Post by hannibal007 » 2013/09/02 20:30:41

same problem still persist !!!!! take a look on screen-shot:

[img align=right]http://i.imgur.com/JJVSe8K.jpg[/img]

[img align=right]http://i.imgur.com/QqV0h41.jpg[/img]

even i tried to comment it with a "ch? bang" and the other directive too such as authoritative, ignore client updates .... but it still doesn't work and it indicates me a semicolon mistake in the first line of the configuration file regarding what any directive it exists !!!!!!

[img align=right]http://i.imgur.com/TcagucU.png[/img]

[img align=right]http://i.imgur.com/1xxzif9.jpg[/img]

i really don't know what to do !!!!!!

[img align=right]http://i.imgur.com/yPsYMPU.jpg[/img]

User avatar
AlanBartlett
Forum Moderator
Posts: 9324
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: DHCP installation PROBLEM

Post by AlanBartlett » 2013/09/02 22:21:39

Either delete the line of hyphens from the file or insert a [b]#[/b] character at the beginning of that line of hyphens.

User avatar
TrevorH
Forum Moderator
Posts: 29145
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: DHCP installation PROBLEM

Post by TrevorH » 2013/09/02 22:35:48

And put back all the hyphens into the keywords that you deleted while trying to fix this! The keywords are "ddns-update-style" not "ddns update style" and "ignore-client-updates" not "ignore client-updates".

Computers are fussy, they like things just exactly how they expect them to be and no other way!

hannibal007
Posts: 9
Joined: 2013/09/01 23:29:28

Re: [SOLVED] DHCP installation PROBLEM

Post by hannibal007 » 2013/09/03 15:09:48

hiiii !!!!!!! thanks admin finally it works !!!!!!!! it's about hyphens surly !!!!!!!!!!!!!!!!!!!!! i've made a succcessive line of hypens to make it as a separator between comments, well i forgot
the ch?-bang before !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! so dummmyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy !!!! loooooooooooooooolllllll have a look :

[img align=right]http://i.imgur.com/jP8x3xv.jpg[/img]

thinks for assistance !!!!! bye !!

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

[SOLVED] DHCP installation PROBLEM

Post by gerald_clark » 2013/09/03 15:19:27

# is not a che-bang.
http://en.wikipedia.org/wiki/Shebang_%28Unix%29

hannibal007
Posts: 9
Joined: 2013/09/01 23:29:28

Re: [SOLVED] DHCP installation PROBLEM

Post by hannibal007 » 2013/09/04 22:09:24

well i've got the LPIC-1 certification and i'm preparing for LPIC-2 exam and since i've learned linux certification session with french language, the "sh" sound is written "ch" in french and the " ? " (accent aigu) is used to make the "e" sound less louder than english pronounciation, and you can notice that on wikipid?a website which it indicates that there is many forms to right the word "shebang"
it doesen't matter how we right it but we must know how and when it should be used !!!!! :-D :-D :-D

Post Reply

Return to “CentOS 5 - Server Support”