TFTP time out error

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Posts: 15
Joined: 2011/09/08 18:41:56

Re: TFTP time out error

Post by charlesgmoore » 2011/09/30 18:35:01

maybe a tail -f /var/log/gmessages and see if anything pops up when you reboot the tftp device.


do a tcpdump for port 69 and see if the device is even hitting the box.

Posts: 5
Joined: 2012/11/07 13:40:11

Re: TFTP time out error

Post by robjoh » 2012/11/07 15:43:03


Did you guys get this solved? Having the same issue, client is hitting the box

16:42:23.773025 IP (tos 0x0, ttl 127, id 25388, offset 0, flags [none], proto UDP (17), length 51) > [udp sum ok] 23 ERROR EUNDEF "timeout on receive"
0x0000: 4500 0033 632c 0000 7f11 b7fa 0a92 086b E..3c,.........k
0x0010: 0a92 0305 e461 0045 001f 63f9 0005 0000 .....a.E..c.....
0x0020: 7469 6d65 6f75 7420 6f6e 2072 6563 6569 timeout.on.recei
0x0030: 7665 00 ve.

output from /var/log/messages

Nov 7 16:42:15 saltdalvgs-fog in.tftpd[21394]: RRQ from filename boot.txt

Posts: 25
Joined: 2014/09/05 00:40:12

Re: TFTP time out error

Post by Locane » 2015/09/22 19:24:37

I had this same problem, and it turned out that my netmask was set wrong.

For the dhcpd.conf, I had a netmask of:

And for the network adapter serving my DHCP (in my case /etc/sysconfig/network-scripts/ifcfg-enp5s0f1), I had a netmask of:

So the DHCP server was issuing an address outside of the range that my network adapter was willing to talk to. I just changed the network adapter netmask to match the DHCP server netmask, and it worked.


Return to “CentOS 5 - Server Support”