running wvdial / pppd as non-root user

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
chriswilliams
Posts: 1
Joined: 2010/06/25 14:18:01

running wvdial / pppd as non-root user

Post by chriswilliams » 2010/06/25 14:31:14

I have recently upgraded from Redhat 7.3 to Centos5.4 and need to get wvdial running to dial out of my server and make a ppp connection.

I have setup the permissions on the executables with sticky bits etc but nothing seems to work.

I have also tried creating a "dialup" group and added the user I need to dial out into that group but nothing seems to be working.

As root I get:

[code]
[root]# wvdial
--> WvDial: Internet dialer version 1.54.0
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATH
ATH
OK
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Sending: ATDT08459122401
--> Waiting for carrier.
ATDT08459122401
CONNECT 115200
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Fri Jun 25 15:24:52 2010
--> pid of pppd: 4756
--> Using interface ppp0
--> pppd: 3
--> pppd: 3
--> pppd: 3
--> pppd: 3
--> pppd: 3
--> local IP address 204.90.246.223
--> pppd: 3
--> remote IP address 204.90.246.1
--> pppd: 3
--> primary DNS address 198.147.177.10
--> pppd: 3
Caught signal #2! Attempting to exit gracefully...
--> Terminating on signal 15
--> pppd: 3
--> Connect time 0.2 minutes.
--> pppd: 3
--> pppd: 3
--> Disconnecting at Fri Jun 25 15:25:09 2010
[/code]
As A N Other user I get:

[code]
[notroot]$ wvdial
--> WvDial: Internet dialer version 1.54.0
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATH
ATH
OK
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Sending: ATDT08459122401
--> Waiting for carrier.
ATDT08459122401
CONNECT 115200
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Fri Jun 25 15:26:10 2010
--> pid of pppd: 4943
--> Disconnecting at Fri Jun 25 15:26:10 2010
--> The PPP daemon has died: pppd options error (exit code = 2)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 2)
[/code]
The man page indicated that I shoud set the sticky bit on pppd - which I have done.

Running pppd as "not root" I see:

[code]
[notroot]$ /usr/sbin/pppd
/usr/sbin/pppd: By default the remote system is required to authenticate itself
/usr/sbin/pppd: (because this system has a default route to the internet)
/usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.
/usr/sbin/pppd: (None of the available passwords would let it use an IP address.)
[/code]
If anyone has any ideas on what would resolve this I would be most appreciative.

Thanks

Chris

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

running wvdial / pppd as non-root user

Post by pschaff » 2010/06/25 14:49:38

Welcome to the CentOS fora. The following reading is recommended for new users:
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14274&forum=47]Readme First[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14408&forum=47]Installing Software[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14273&forum=47]Where to Find Answers[/url]
[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=25128&forum=47]How to provide information about your system[/url]

Afraid I haven't used dialup since RH 7.3 was a current release, so won't be a lot of help, but I'd try using either system-config-network or NetworkManager (not both) to set it up.

chuina
Posts: 355
Joined: 2009/12/11 10:25:56

Re: running wvdial / pppd as non-root user

Post by chuina » 2010/06/26 12:34:11

I use [url=http://wiki.centos.org/TipsAndTricks/BecomingRoot]Becoming Root[/url] for running wvdial as non-root user.

Post Reply

Return to “CentOS 5 - Server Support”