YUM Error

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
Posts: 3
Joined: 2010/05/16 13:02:17

YUM Error

Post by nmatthew » 2010/05/16 13:07:53

When using any [code]yum install <package>[/code] command, I get:

[root@nic ~]# yum install package
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in ?
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/yummain.py", line 229, in user_main
errcode = main(args)
File "/usr/share/yum-cli/yummain.py", line 104, in main
result, resultmsgs = base.doCommands()
File "/usr/share/yum-cli/cli.py", line 339, in doCommands
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 101, in _getTs
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 112, in _getTsInfo
pkgSack = self.pkgSack
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 591, in
pkgSack = property(fget=lambda self: self._getSacks(),
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 434, in _getSacks
File "/usr/lib/python2.4/site-packages/yum/repos.py", line 223, in populateSack
File "/usr/lib/python2.4/site-packages/yum/repos.py", line 71, in doSetup
File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 176, in run
func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/fastestmirror.py", line 181, in postreposetup_hook
all_urls = FastestMirror(all_urls).get_mirrorlist()
File "/usr/lib/yum-plugins/fastestmirror.py", line 333, in get_mirrorlist
File "/usr/lib/yum-plugins/fastestmirror.py", line 376, in _poll_mirrors
File "/usr/lib/python2.4/threading.py", line 416, in start
_start_new_thread(self.__bootstrap, ())
thread.error: can't start new thread

Any ideas? Thanks so much for any help!

Posts: 355
Joined: 2009/12/11 10:25:56

Re: YUM Error

Post by chuina » 2010/05/16 13:56:51

Welcome to the CentOS

Required readings for all new members are [url=http://www.centos.org/modules/newbb/viewforum.php?forum=47]FAQ & Readme First[/url].

Provide the info of [b]./getinfo.sh package[/b] instructed at [url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=25128&forum=47]How to Provide Information About Your System[/url]

Posts: 3
Joined: 2010/05/16 13:02:17

Re: YUM Error

Post by nmatthew » 2010/05/16 15:16:50


[root@nic ~]# ./getinfo.sh package
./getinfo.sh: fork: Cannot allocate memory

Posts: 3
Joined: 2010/05/16 13:02:17

Re: YUM Error

Post by nmatthew » 2010/05/16 15:20:49

Well, I just restarted the server trying to free up some more memory, and then tried yum install again, and it worked!

Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

YUM Error

Post by pschaff » 2010/05/17 20:29:19

Glad to see that worked and thanks for posting back. Will be looking forward to your next thread about finding memory leaks in applications. :-)

Post Reply

Return to “CentOS 5 - Server Support”