postfix & Dovecot setup

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
slick101
Posts: 35
Joined: 2010/02/19 02:38:34

postfix & Dovecot setup

Post by slick101 » 2010/03/04 20:47:42

I am setting up a mail server and I am following this article

http://wiki.centos.org/HowTos/postfix

when I try to start the services


[root@host4] home >> /etc/init.d/dovecot start
Starting Dovecot Imap: /usr/sbin/dovecot: error while loading shared libraries: libc.so.6: cannot open shared object file: Permission denied
[FAILED]
[root@host4] ~ >> /etc/init.d/postfix start
Starting postfix: [FAILED]


I made sure that their are no leading spaces on the lines i edit but everything seems okay.

Any idea on the permission issue? Would this cause postfix form starting also?

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: postfix & Dovecot setup

Post by pschaff » 2010/03/04 20:53:46

Seems to be a library issue, not a permission issue. Please show[code]
uname -rmi
rpm -q centos-release postfix dovecot
rpm -qa glibc\*
[/code]

slick101
Posts: 35
Joined: 2010/02/19 02:38:34

Re: postfix & Dovecot setup

Post by slick101 » 2010/03/04 20:57:16

Sure..learning as I do this did not know about some these commands


[root@host4] postfix >> uname -rmi
2.6.18-164.11.1.el5 x86_64 x86_64

[root@host4] postfix >> rpm -q centos-release postfix dovecot
centos-release-5-4.el5.centos.1
postfix-2.3.3-2.1.el5_2
dovecot-1.0.7-7.el5

[root@host4] postfix >> rpm -qa glibc\*
glibc-2.5-42.el5_4.3
glibc-2.5-42.el5_4.3
glibc-devel-2.5-42.el5_4.3
glibc-common-2.5-42.el5_4.3
glibc-headers-2.5-42.el5_4.3

michaelnel
Posts: 1478
Joined: 2006/05/29 16:50:11
Location: San Francisco, CA

postfix & Dovecot setup

Post by michaelnel » 2010/03/04 21:01:37

Actually, I suspect selinux. What is the output of "sestatus"?

Also please show "ls -Z /usr/sbin/dovecot" and "ls -Z /lib/libc*"

Thanks

slick101
Posts: 35
Joined: 2010/02/19 02:38:34

Re: postfix & Dovecot setup

Post by slick101 » 2010/03/04 21:03:44

[root@host4] etc >> sestatus
SELinux status: enabled
SELinuxfs mount: /selinux
Current mode: enforcing
Mode from config file: enforcing
Policy version: 21
Policy from config file: targeted

[root@host4] etc >> ls -Z /usr/sbin/dovecot
-rwxr-xr-x root root system_u:object_r:dovecot_exec_t /usr/sbin/dovecot

[root@host4] etc >> ls -Z /lib/libc*
-rwxr-xr-x root root system_u:object_r:file_t /lib/libc-2.5.so
lrwxrwxrwx root root system_u:object_r:file_t /lib/libcap.so.1 -> libcap.so.1.10
-rwxr-xr-x root root system_u:object_r:file_t /lib/libcap.so.1.10
-rwxr-xr-x root root system_u:object_r:file_t /lib/libcidn-2.5.so
lrwxrwxrwx root root system_u:object_r:file_t /lib/libcidn.so.1 -> libcidn-2.5.so
lrwxrwxrwx root root system_u:object_r:file_t /lib/libcom_err.so.2 -> libcom_err.so.2.1
-rwxr-xr-x root root system_u:object_r:file_t /lib/libcom_err.so.2.1
-rwxr-xr-x root root system_u:object_r:file_t /lib/libcrypt-2.5.so
-rwxr-xr-x root root system_u:object_r:file_t /lib/libcrypto.so.0.9.8e
lrwxrwxrwx root root system_u:object_r:file_t /lib/libcrypto.so.6 -> libcrypto.so.0.9.8e
lrwxrwxrwx root root system_u:object_r:file_t /lib/libcrypt.so.1 -> libcrypt-2.5.so
lrwxrwxrwx root root system_u:object_r:file_t /lib/libc.so.6 -> libc-2.5.so

I did recently enabled selinux.

slick101
Posts: 35
Joined: 2010/02/19 02:38:34

Re: postfix & Dovecot setup

Post by slick101 » 2010/03/04 21:28:16

I disabled selinux now and following:


[root@host4] ~ >> /etc/init.d/dovecot start
Starting Dovecot Imap:
[root@host4] ~ >> /etc/init.d/postfix start
Starting postfix: [FAILED]

michaelnel
Posts: 1478
Joined: 2006/05/29 16:50:11
Location: San Francisco, CA

Re: postfix & Dovecot setup

Post by michaelnel » 2010/03/04 23:04:01

So dovecot started but postfix did not?

Take a look at /var/log/maillog and /var/log/messages for clues as to what is making postfix cranky.
We can deal with the selinux issue after you get 'em running without it.

"/usr/sbin/postconf -n" will give you a nice list of the parameters in your config that have been changed
from the defaults.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: postfix & Dovecot setup

Post by pschaff » 2010/03/05 00:11:18

[quote]
michaelnel wrote:
So dovecot started but postfix did not?
[/quote]
I would not conclude that dovecot started. No - [ [b][color=00CC00]OK[/color][/b] ].

michaelnel
Posts: 1478
Joined: 2006/05/29 16:50:11
Location: San Francisco, CA

Re: postfix & Dovecot setup

Post by michaelnel » 2010/03/05 00:24:56

I didn't assume it started, that's why there was a question mark at the end of the sentence.

I noticed no OK, but it could have been cut off in cut & paste or something. In any case, it didn't seem to have generated the same error message.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: postfix & Dovecot setup

Post by pschaff » 2010/03/05 00:40:18

Yup. Service startup failures often seem to be mysteriously silent.

Post Reply

Return to “CentOS 5 - Server Support”