Page 1 of 2

tape device unknown!!!!

Posted: 2008/10/21 12:32:33
by saman_artorious
Hi

I am new to linux. I realized that centOS does not support the mt command
So, I downloaded mt(1) package mt-st-0.9b-2.2.2

now, when i want to rewind the tape device using the command: mt -f /dev/st0 rewind
I receive the following: /dev/st0: No such file or directory


I found out that the device type is different for CentOS. that is sg0
but again when i type the command mt -f /dev/sg0 rewind
I receive this error: /dev/sg0: Operation not permitted

please help me
uname -a
Linux localhost.localdomain 2.6.18-8.el5 #1 SMP Thu Mar 15 19:57:35 EDT 2007 i686 i686 i386 GNU/Linux


Regards
Saman

Re: tape device unknown!!!!

Posted: 2008/10/21 13:15:22
by gerald_clark
Remove the foreign mt package and install the one that comes with CentOS.

yum install mt-st

Re: tape device unknown!!!!

Posted: 2008/10/21 14:37:33
by saman_artorious
I did, I have already installed that package on my system using yum.
but I don't find the st0 device in /dev,
should i use a different one for CentOS?

Re: tape device unknown!!!!

Posted: 2008/10/21 15:24:01
by gerald_clark
Does the drive show up in dmesg ?
If not, you probably need to load the driver for your scsi controller.

Re: tape device unknown!!!!

Posted: 2008/10/21 17:24:17
by saman_artorious
dmesg | grep sg0
sd 0:0:0:0: Attached scsi generic sg0 type 0

dmesg | grep st0
(nothing)

what should i do now?
is sg0 used in centos instead of st0? if it does, i cannot access the tape using : mt -f /dev/sg0 rewind

if not how can i use st0?

Re: tape device unknown!!!!

Posted: 2008/10/21 17:37:42
by gerald_clark
If dmesg does not show anything identified as a tape drive, then
the proper driver is not loaded.

Re: tape device unknown!!!!

Posted: 2008/10/21 18:15:06
by saman_artorious
how can i load tape device properly and backup my system?

Re: tape device unknown!!!!

Posted: 2008/10/21 18:17:41
by gerald_clark
I don't know.
I have no idea what your scsi controller and
tape drive are.

Re: tape device unknown!!!!

Posted: 2008/10/27 18:43:02
by michaelnel
Please show the output of "cat /proc/scsi/scsi"

Re: tape device unknown!!!!

Posted: 2014/01/28 15:16:30
by vin
hello guys...!!!

i am new on the linux and even though i am facing the same issue please help.

saman_artorious if you solve this problem then please help me too.

Thankyou in advance