No mouse in X

Issues related to hardware problems
Post Reply
Posts: 5
Joined: 2011/09/06 14:24:54

No mouse in X

Post by mike_b » 2016/09/16 19:50:56

I have been using an Asterisk system on Centos5.5 for a while and it has worked fine. The computer is now getting *really* old and has had some hiccups, so I decided to move to a newer hardware. I put together a computer based on an Intel I3 processor, and I am planning to install the same version of Centos/Asterisk/FreePBX there, to make the transfer easier.
The PC boots up fine, and I can get into the BIOS and change things with teh mouse and keyboard (both connected to USB2).
When I start the installation, and the Centos installation screen comes up, the keyboard still works, but no mouse I have tried (2 different USB, 1 PS/2) seems to work.
After the full installation, I have tried to install a GUI (X Windows), and I have no mouse there either. There is an "X" looking cursor in the center of the screen, but no movement. The screen also looks frozen. I see a console window (but I can't go there), and a clock in the UR corner, but nothing else. The keyboard is alive, as I can ctrl-Alt-Backspace to kill X-Windows. But that's all I can do.
I have tried xorg -configure and moved the xorg.conf file, but no success.

This is a fresh installation with nothing else done to the system.

Any idea how I can get this going? I know that FreePBX runs without a GUI, but the transfer of the Asterisk configuration files is probably much easier with a GUI ...

User avatar
Forum Moderator
Posts: 30173
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: No mouse in X

Post by TrevorH » 2016/09/16 21:22:25

Really, don't install CentOS 5 now. It goes out of support in 6 months or so and there will be no more security updates for it. Take this opportunity to upgrade to a more recent version of the distro.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 5 - Hardware Support”