[SOLVED] Another problem using yum........

Issues related to software problems.
Post Reply
sairaj
Posts: 13
Joined: 2014/02/21 13:37:21

[SOLVED] Another problem using yum........

Post by sairaj » 2014/03/26 04:15:50

HI
im trying to remove wine but this is what happens...................
[root@localhost ~]# yum remove wine
Loaded plugins: fastestmirror, priorities
Existing lock /var/run/yum.pid: another copy is running as pid 5510.
Another app is currently holding the yum lock; waiting for it to exit...
The other application is: yum
Memory : 17 M RSS ( 58 MB VSZ)
Started: Wed Mar 26 09:33:27 2014 - 03:34 ago
State : Sleeping, pid: 5510
Another app is currently holding the yum lock; waiting for it to exit...
The other application is: yum
Memory : 20 M RSS ( 62 MB VSZ)
Started: Wed Mar 26 09:33:27 2014 - 03:36 ago
State : Running, pid: 5510
Another app is currently holding the yum lock; waiting for it to exit...
The other application is: yum
Memory : 17 M RSS ( 58 MB VSZ)
Started: Wed Mar 26 09:33:27 2014 - 03:38 ago
State : Sleeping, pid: 5510
Another app is currently holding the yum lock; waiting for it to exit...
The other application is: yum
Memory : 17 M RSS ( 58 MB VSZ)
Started: Wed Mar 26 09:33:27 2014 - 03:40 ago
State : Sleeping, pid: 5510
Setting up Remove Process
No Match for argument: wine
Loading mirror speeds from cached hostfile
* base: ftp.iitm.ac.in
* c5-media:
* centosplus: ftp.iitm.ac.in
* contrib: ftp.iitm.ac.in
* extras: ftp.iitm.ac.in
* rpmforge: mirror.oscc.org.my
* rpmforge-extras: mirror.oscc.org.my
* rpmforge-testing: mirror.oscc.org.my
* updates: ftp.iitm.ac.in
C5.5-extras/primary_db | 183 kB 00:01
C5.5-updates | 1.9 kB 00:00
C5.5-updates/primary_db | 911 kB 00:06
C5.6-base | 1.1 kB 00:00
C5.6-base/primary | 954 kB 00:14
C5.6-base 2683/2683
C5.6-centosplus | 1.9 kB 00:00
C5.6-centosplus/primary_db | 99 kB 00:01
C5.6-extras | 2.1 kB 00:00
C5.6-extras/primary_db | 183 kB 00:01
C5.6-updates | 1.9 kB 00:00
C5.6-updates/primary_db | 627 kB 00:04
C5.7-base | 1.1 kB 00:00
C5.7-base/primary | 961 kB 00:06
C5.7-base 2705/2705
C5.7-centosplus | 1.9 kB 00:00
C5.7-extras | 2.1 kB 00:00
C5.7-updates | 1.9 kB 00:00
C5.8-base | 1.1 kB 00:00
C5.8-centosplus | 1.9 kB 00:00
C5.8-extras | 2.1 kB 00:00
C5.8-updates | 1.9 kB 00:00
C5.9-base | 1.1 kB 00:00
C5.9-centosplus | 1.9 kB 00:00
C5.9-extras | 2.1 kB 00:00
C5.9-updates | 1.9 kB 00:00
file:///media/CentOS/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/CentOS/repodata/repomd.xml'
Trying other mirror.
file:///media/cdrecorder/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/cdrecorder/repodata/repomd.xml'
Trying other mirror.
file:///media/cdrom/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/cdrom/repodata/repomd.xml'
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: c5-media. Please verify its path and try again
[root@localhost ~]# yum remove wine
Loaded plugins: fastestmirror, priorities
Setting up Remove Process
No Match for argument: wine
Loading mirror speeds from cached hostfile
* base: ftp.iitm.ac.in
* c5-media:
* centosplus: ftp.iitm.ac.in
* contrib: ftp.iitm.ac.in
* extras: ftp.iitm.ac.in
* rpmforge: mirror.oscc.org.my
* rpmforge-extras: mirror.oscc.org.my
* rpmforge-testing: mirror.oscc.org.my
* updates: ftp.iitm.ac.in
file:///media/CentOS/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/CentOS/repodata/repomd.xml'
Trying other mirror.
file:///media/cdrecorder/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/cdrecorder/repodata/repomd.xml'
Trying other mirror.
file:///media/cdrom/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/cdrom/repodata/repomd.xml'
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: c5-media. Please verify its path and try again
[root@localhost ~]#

WHAT SHOULD BE DONE :?: :?: :?: :?: :?:
THANKS

User avatar
TrevorH
Forum Moderator
Posts: 29120
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Another problem using yum........

Post by TrevorH » 2014/03/26 04:36:06

Why have you enabled every single repo you have?

You should edit the files in /etc/yum.repos.d and change "enabled=1" back to "enabled=0" for everything in CentOS-Vault.repo. In addition you should also disable c5-media, centosplus, contrib, rpmforge-extras, rpmforge-testing in the various other files in that directory. The only ones you want enabled are base, updates and extras and, possibly, rpmforge.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

sairaj
Posts: 13
Joined: 2014/02/21 13:37:21

Re: Another problem using yum........

Post by sairaj » 2014/03/27 06:45:48

THANKS
i followed the steps and worked fine ....
thank u

Post Reply

Return to “CentOS 5 - Software Support”