LogicalVolume Name issue when using vgdisplay/vgextend

Issues related to software problems.
Post Reply
divekeys
Posts: 1
Joined: 2014/02/24 17:19:38

LogicalVolume Name issue when using vgdisplay/vgextend

Post by divekeys » 2014/02/24 19:32:26

After adding disk to the VM the vgextent and even vgdisplay have issues with our volume names.
I’m running into issues running the vgextend command the way we have our volumes named. I was able to add disk successfully to the root but can’t get it to work on the /var directory due to the way its named.

Even running vgdisplay presents issues.

Our naming convention appears to be /dev/mapper/VolGroup00-LogVol1xx

When you run a vgdisplay against this name

[root@~]# vgdisplay /dev/mapper/VolGroup00-LogVol02
Invalid volume group name: VolGroup00/LogVol02
Run `vgdisplay --help' for more information.

The same thing happens if I try to vgextend. If I only use VolGroup00 (without the LogVol02) it works, but allocates space in the root instead of the /var directory. I need to expand the space in the /var directory which sits on /dev/mapper/VolGroup00-LogVol02.

[root@~]# vgextend /dev/mapper/VolGroup00-LogVol02 /dev/sda4
Volume group name VolGroup00/LogVol02 has invalid characters
Last edited by divekeys on 2014/02/24 20:09:36, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 29147
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Volume group name issue when using vgdisplay/vgextend

Post by TrevorH » 2014/02/24 19:55:14

[root@~]# vgextend /dev/mapper/VolGroup00-LogVol02 /dev/sda4
But /dev/mapper/VolGroup00-LogVol02 is not a volume group name, it's a logical volume name. To see what your VG names are, run `vgs`.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Volume group name issue when using vgdisplay/vgextend

Post by gerald_clark » 2014/02/24 19:56:57

You are attempting to vgextend a volume, not a volume group.
You might want to read http://tldp.org/HOWTO/LVM-HOWTO/
and
https://access.redhat.com/site/document ... index.html

Post Reply

Return to “CentOS 5 - Software Support”