[SOLVED] rhel 5.8 can't upgrade any further

Issues related to software problems.
Post Reply
skwysham
Posts: 13
Joined: 2013/07/16 20:26:28

[SOLVED] rhel 5.8 can't upgrade any further

Post by skwysham » 2014/01/16 17:48:59

I have inherited a rhel 5.8 vm. I don't have rh support so I want to use elrepo and/or centos repositories to continue supporting it. Here's the repos lists
[root@bigdata etc]# yum repolist
Loaded plugins: security
repo id repo name status
Centos5Updates Centos5Updates 223
adobe-linux-x86_64 Adobe Systems Incorporated 2
elrepo ELRepo.org Community Enterprise Linux Repository - el5 395
elrepo-extras ELRepo.org Community Enterprise Linux Extras Repository - el5 57
elrepo-kernel ELRepo.org Community Enterprise Linux Kernel Repository - el5 8
repolist: 685

I added Centos5Updates to the list of repos. because there seems to be no kernal updates via the elrepo repositories. I got into this situation because I need libXp.so.6 64 bit. NowI seem to be caught in some dependency circle trying to get out of the ditch, i.e. when trying to update "everything possible"
Missing Dependency: e2fsprogs >= 1.39-36 is needed by package mkinitrd-5.1.19.6-81.el5_10.i386 (Centos5Updates)
Missing Dependency: device-mapper-multipath >= 0.4.7-50 is needed by package mkinitrd-5.1.19.6-81.el5_10.i386 (Centos5Updates)
Missing Dependency: e2fsprogs >= 1.39-36 is needed by package mkinitrd-5.1.19.6-81.el5_10.x86_64 (Centos5Updates)
Missing Dependency: device-mapper-multipath >= 0.4.7-50 is needed by package mkinitrd-5.1.19.6-81.el5_10.x86_64 (Centos5Updates)
Missing Dependency: libsqlite3.so.0 is needed by package nss-3.15.3-4.el5_10.i386 (Centos5Updates)

and don't ask about GLIBC dependencies!!

How do I start over with the repositories to and the rpm database so that I can upgrade the kernal and packages?

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: rhel 5.8 can't upgrade any further

Post by gerald_clark » 2014/01/16 18:09:50

Please read the wiki migration guide.
http://wiki.centos.org/HowTos/MigrationGuide

skwysham
Posts: 13
Joined: 2013/07/16 20:26:28

SOLVED Re: rhel 5.8 can't upgrade any further

Post by skwysham » 2014/01/16 20:51:41

Thanks!

Post Reply

Return to “CentOS 5 - Software Support”