Sikuli and Tesseract dependency problem

Issues related to software problems.
Post Reply
worm
Posts: 2
Joined: 2013/12/16 16:55:32

Sikuli and Tesseract dependency problem

Post by worm » 2013/12/16 17:01:51

Hello,

I'm having a few issues to use Sikuli (UI automation tool) on CentOS 5.10.

It's dependent on Tesseract 3.00 so I had to build it from sources since there is no rpm provided in either the default CentOS repo or EPEL for this version.

The problem is I can't make Tesseract build his libraries into /usr/lib64 which is the directory Sikuli looks for.
I've tried ./configure --prefix=/usr/lib64 but I get error: cannot install `libtesseract_main.la' to a directory not ending in /usr/local/lib.

Also it seems Sikuli only looks for libtesseract.so.3 whereas Tesseract builds all of these .so files : http://pastebin.com/KMa1TNn2
Here's the runtime error I get when trying to run a Sikuli test:

/root/sikuli/libs/libVisionProxy.so: libtesseract.so.3: Can't open shared object: No such file or directory of this type

Thank you in advance.

pjwelsh
Posts: 2619
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: Sikuli and Tesseract dependency problem

Post by pjwelsh » 2013/12/17 13:36:55

I haven't tried, but does the "CentOS 6.4 x86_64: How to Install SikuliX 1.0.1" from https://answers.launchpad.net/sikuli/+question/236625 help?

worm
Posts: 2
Joined: 2013/12/16 16:55:32

Re: Sikuli and Tesseract dependency problem

Post by worm » 2013/12/17 14:39:59

I've tried using http://rpm.pbone.net/ to look for these rpm packages for C5 and RHEL5 using the advanced search.
  1. Leptonica: only one package found fails to install with:
    error: Required dependencies:
    liblept.so.3()(64bit) is necessary for liblept-devel-1.69-2.1.x86_64
    liblept2 = 1.69 is necessary for liblept-devel-1.69-2.1.x86_64
    So I've build it using sources from here.
  2. Tesseract: this package fails to install with:
    error: Required dependencies:
    libtesseract_api.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_ccstruct.so.3()(64bit) is necessary foris necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_ccutil.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_classify.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_cube.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_cutil.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_dict.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_image.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_main.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_neural.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_tessopt.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_textord.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_training.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_viewer.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    libtesseract_wordrec.so.3()(64bit) is necessary for tesseract-devel-3.01-51.1.x86_64
    tesseract = 3.01 is necessary for tesseract-devel-3.01-51.1.x86_64
    this package fails to install with:
    error: Required dependencies:
    liblept.so.2()(64bit) is necessary for tesseract-3.01-51.1.x86_64
    Even though I built and installed Leptonica from sources:

    Code: Select all

    # locate liblept
    /usr/local/lib/liblept.a
    /usr/local/lib/liblept.la
    /usr/local/lib/liblept.so
    /usr/local/lib/liblept.so.2
    /usr/local/lib/liblept.so.2.0.0
    I've tried to symlink them:

    Code: Select all

    ln -s /usr/local/lib/liblept* /usr/lib64/
    ln -s /usr/local/lib/liblept* /usr/local/lib64/
    But it makes no difference.
What else could I try?

Post Reply

Return to “CentOS 5 - Software Support”