Page 1 of 1

Where to find rpm for libblkid

Posted: 2012/12/15 17:13:49
by kclo2000
I need to install a application which require libblkid package. I can find it under CentOS6 but can't find it from CentOS 5.

Any suggestions?

Thanks!

Where to find rpm for libblkid

Posted: 2012/12/15 19:29:00
by AlanBartlett
Let's see --

[code]
[ajb@Build64R5 ~]$ sudo yum provides \*/libblkid\*
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
[i]<snip>[/i]
Finished
man-pages-ja-20060815-15.el5.noarch : Japanese man (manual) pages from the Japanese Manual Project
Repo : fastrack
Matched from:
Filename : /usr/share/man/ja/man3/libblkid.3.gz

man-pages-ja-20060815-15.el5.noarch : Japanese man (manual) pages from the Japanese Manual Project
Repo : os
Matched from:
Filename : /usr/share/man/ja/man3/libblkid.3.gz

e2fsprogs-devel-1.39-33.el5.x86_64 : Ext2/3 filesystem-specific static libraries and headers
Repo : os
Matched from:
Filename : /usr/lib64/libblkid.so
Filename : /usr/lib64/libblkid.a
Filename : /usr/share/man/man3/libblkid.3.gz

e2fsprogs-libs-1.39-33.el5.x86_64 : Ext2/3 filesystem-specific static libraries and headers
Repo : os
Matched from:
Filename : /lib64/libblkid.so.1
Filename : /lib64/libblkid.so.1.0

man-pages-ja-20060815-15.el5.noarch : Japanese man (manual) pages from the Japanese Manual Project
Repo : updates
Matched from:
Filename : /usr/share/man/ja/man3/libblkid.3.gz

e2fsprogs-libs-1.39-34.el5_8.1.x86_64 : Ext2/3 filesystem-specific static libraries and headers
Repo : updates
Matched from:
Filename : /lib64/libblkid.so.1
Filename : /lib64/libblkid.so.1.0

e2fsprogs-devel-1.39-34.el5_8.1.x86_64 : Ext2/3 filesystem-specific static libraries and headers
Repo : updates
Matched from:
Filename : /usr/lib64/libblkid.so
Filename : /usr/lib64/libblkid.a
Filename : /usr/share/man/man3/libblkid.3.gz

e2fsprogs-libs-1.39-34.el5_8.1.x86_64 : Ext2/3 filesystem-specific static libraries and headers
Repo : installed
Matched from:
Filename : /lib64/libblkid.so.1
Filename : /lib64/libblkid.so.1.0

e2fsprogs-devel-1.39-34.el5_8.1.x86_64 : Ext2/3 filesystem-specific static libraries and headers
Repo : installed
Matched from:
Filename : /usr/lib64/libblkid.so
Filename : /usr/share/man/man3/libblkid.3.gz
Filename : /usr/lib64/libblkid.a

[ajb@Build64R5 ~]$
[/code]
So the suggestion is to --

[code]
[b]yum install e2fsprogs-libs e2fsprogs-devel[/b]
[/code]

Re: Where to find rpm for libblkid

Posted: 2012/12/17 10:54:04
by kclo2000
Thanks for your reply.

I have installed e2fsprogs-libs e2fsprogs-devel. However, when I install the application(actually it is appassure agent client), it still states that libbliid package is not available. I have checked that CentOS6 come with this yum package. Can CentOS5 also have this package.

Re: Where to find rpm for libblkid

Posted: 2012/12/18 01:33:57
by AlanBartlett
[quote]
Can CentOS5 also have this package.
[/quote]
Yes. That is what I showed in post #2.

[code]
[ajb@Build64R5 ~]$ rpm -ql e2fsprogs-libs | grep libblkid
/lib64/libblkid.so.1
/lib64/libblkid.so.1.0
[ajb@Build64R5 ~]$ rpm -ql e2fsprogs-devel | grep libblkid
/usr/lib64/libblkid.a
/usr/lib64/libblkid.so
/usr/share/man/man3/libblkid.3.gz
[ajb@Build64R5 ~]$
[/code]

Re: Where to find rpm for libblkid

Posted: 2014/03/20 18:07:53
by edman545
kclo2000, did you ever get this working? I am also trying to get appassure to protect Centos5 and I am getting stuck at this same dependency. I tried the suggestion mentioned in post #2, but no joy.

Re: Where to find rpm for libblkid

Posted: 2014/03/20 23:13:30
by toracat
Is this software provided by Dell? If so, you may want to try and ask in their support venue (forums?). Hopefully there are CentOS/RHEL/SL users who have an answer to this issue.

Re: Where to find rpm for libblkid

Posted: 2014/03/20 23:21:18
by TrevorH
There is no mention of CentOS 5 (or RHEL5) support here