yum priorities problem

Issues related to software problems.
mjpm
Posts: 4
Joined: 2007/09/01 18:41:35

yum priorities problem

Post by mjpm » 2007/11/03 12:20:13

Hello everyone,
I have a problem regarding yum and yum-priorities.

Following situation:
I did a clean instal of CentOS5 from DVD. Then installed yum-priorities (and yum-fastestmirror) according to the wiki.
Priorities are set to 1 for base and updates.
When enabling rpmforge repository I set its priority to 11.
This all happened before doing any updates.

Now, when running yum check-update yum wants to install the following packages as dependencies (which is ok for me):
avahi-compat-howl, meanwhile, perl-URI, perl-libwww-perl
and yum wants to update (beside a bunch of updates from 'update') package
perl-Compress-Zlib
from 'rpmforge' repository, which seems wrong to me.

As written above, 'base' and 'update' have priority 1 and 'rpmforge' has priority 11.
Priority seem to work as yum excludes 269 packages due to repository priority protections.

Versions are:
installed (base): perl-Compress-Zlib.i386: 1.42-1.fc6
update (rpmforge): perl-Compress-Zlib.noarch: 2.005-1.el5.rf

If I do an update with disabled 'rpmforge' and re-enable it afterwards, yum still treats the package as update.
As additional information, obsolete checks are enabled both in yum and in yum priorites plugin.

I appreciate any hints or a explanations for this behavior.

User avatar
toracat
Forum Moderator
Posts: 7457
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: yum priorities problem

Post by toracat » 2007/11/03 13:03:59

That is very odd. It is working fine on my systems. Just to be sure ... could you check your rpmforge.repo file and the line priority=11 is spelled correctly ?

mjpm
Posts: 4
Joined: 2007/09/01 18:41:35

Re: yum priorities problem

Post by mjpm » 2007/11/03 13:51:54

I double-checked it again and also did a check-update test with different priorities on rpmforge.repo:

priority=11 / priority=99
[code]Loading "priorities" plugin
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
151 packages excluded due to repository priority protections

perl-Compress-Zlib.noarch 2.005-1.el5.rf rpmforge[/code]

priority=1:
[code]Loading "priorities" plugin
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
0 packages excluded due to repository priority protections

agg.i386 2.5-1.el5.rf rpmforge
cadaver.i386 0.22.5-1.el5.rf rpmforge
iso-codes.noarch 1.0a-1.el5.rf rpmforge
lftp.i386 3.5.14-1.el5.rf rpmforge
mtr.i386 2:0.72-1.el5.rf rpmforge
perl-Archive-Tar.noarch 1.32-1.el5.rf rpmforge
perl-Compress-Zlib.noarch 2.005-1.el5.rf rpmforge
perl-IO-Socket-SSL.noarch 1.07-2.el5.rf rpmforge
perl-IO-Zlib.noarch 1.05-1.el5.rf rpmforge
perl-Net-DNS.i386 0.61-1.el5.rf rpmforge
rsync.i386 2.6.9-1.el5.rf rpmforge
spamassassin.i386 3.2.3-1.el5.rf rpmforge
syslinux.i386 3.52-1.el5.rf rpmforge[/code]

So it seems to work on all packages but perl-Compress.Zlib.
This is really odd.

User avatar
toracat
Forum Moderator
Posts: 7457
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: yum priorities problem

Post by toracat » 2007/11/03 14:07:28

This is so puzzling. Just one more attempt:

yum clean all

mjpm
Posts: 4
Joined: 2007/09/01 18:41:35

Re: yum priorities problem

Post by mjpm » 2007/11/03 14:25:24

Yes, tested this a few times before. No different result.
For testing I disabled fastestmirror plugin and disabled everything except base, updates and rpmforge with the same result as before.

User avatar
toracat
Forum Moderator
Posts: 7457
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: yum priorities problem

Post by toracat » 2007/11/03 15:38:53

Hmm.. I cannot reproduce your problem on my machine.

# yum list perl-Compress-Zlib
Loading "installonlyn" plugin
Loading "kmdl" plugin
Loading "fastestmirror" plugin
Loading "repolist" plugin
Loading "priorities" plugin
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Excluding Packages from CentOS-5 - Updates
Finished
Excluding Packages from CentOS-5 - Base
Finished
Excluding Packages from CentOS-5 - Extras
Finished
340 packages excluded due to repository priority protections
Installed Packages
perl-Compress-Zlib.x86_64 1.42-1.fc6 installed
Available Packages
perl-Compress-Zlib.noarch 2.005-1.el5.rf rpmforge

User avatar
toracat
Forum Moderator
Posts: 7457
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: yum priorities problem

Post by toracat » 2007/11/03 17:07:47

Could you file a report at http://bugs.centos.org ? CentOS developers need to look at this issue. You can refer to this thread in that report.

Thanks.

mjpm
Posts: 4
Joined: 2007/09/01 18:41:35

Re: yum priorities problem

Post by mjpm » 2007/11/03 19:43:08

OK, here we go:

[url=http://bugs.centos.org/view.php?id=2428]http://bugs.centos.org/view.php?id=2428[/url]

;-)

User avatar
toracat
Forum Moderator
Posts: 7457
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: yum priorities problem

Post by toracat » 2007/11/07 18:45:59

Could you try the revised version of priorities.py provided by danieldk in the bug tracker? It seems to fix the problem you are experiencing. Please post your result in that report.

iLukeBerry
Posts: 3
Joined: 2009/09/20 18:15:20

Re: yum priorities problem

Post by iLukeBerry » 2009/09/20 18:47:23

i have the same problem.. fresh install of CentOS 5.3!

[code]
[root@cryostasis yum.repos.d]# yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* rpmforge: ftp-stud.fht-esslingen.de
* base: mirror.lihnidos.org
* updates: mirror.lihnidos.org
* addons: mirror.lihnidos.org
* extras: mirror.lihnidos.org
412 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package swig.i386 0:1.3.29-2.el5 set to be updated
---> Package perl-IO-Compress.noarch 0:2.021-1.el5.rf set to be updated
--> Processing Dependency: perl(Compress::Raw::Bzip2) >= 2.021 for package: perl-IO-Compress
--> Processing Dependency: perl(Compress::Raw::Zlib) >= 2.021 for package: perl-IO-Compress
---> Package splint.i386 0:3.1.1-16.el5 set to be updated
--> Running transaction check
---> Package perl-Compress-Raw-Zlib.i386 0:2.021-1.el5.rf set to be updated
---> Package perl-Compress-Raw-Bzip2.i386 0:2.021-1.el5.rf set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================
Package Arch Version Repository Size
=============================================================================================================================================
Installing:
perl-IO-Compress noarch 2.021-1.el5.rf rpmforge 238 k
replacing perl-Compress-Zlib.i386 1.42-1.fc6

Updating:
splint i386 3.1.1-16.el5 base 1.5 M
swig i386 1.3.29-2.el5 base 2.9 M
Installing for dependencies:
perl-Compress-Raw-Bzip2 i386 2.021-1.el5.rf rpmforge 108 k
perl-Compress-Raw-Zlib i386 2.021-1.el5.rf rpmforge 169 k

Transaction Summary
=============================================================================================================================================
Install 3 Package(s)
Update 2 Package(s)
Remove 0 Package(s)

Total download size: 4.9 M
Is this ok [y/N]: n
[/code]
priority in rpmforge.repo is set to 11
And priorities in CentOS-Base.repo are set according to centos wiki about rpmforge.
I don't know why it wants to replace perl-Compress-Zlib.i386 1.42-1.fc6 with perl-IO-Compress from rpmforge

Post Reply

Return to “CentOS 5 - Software Support”