yum priorities problem

Issues related to software problems.
iLukeBerry
Posts: 3
Joined: 2009/09/20 18:15:20

Re: yum priorities problem

Post by iLukeBerry » 2009/09/20 18:47:23

i have the same problem.. fresh install of CentOS 5.3!

[code]
[root@cryostasis yum.repos.d]# yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* rpmforge: ftp-stud.fht-esslingen.de
* base: mirror.lihnidos.org
* updates: mirror.lihnidos.org
* addons: mirror.lihnidos.org
* extras: mirror.lihnidos.org
412 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package swig.i386 0:1.3.29-2.el5 set to be updated
---> Package perl-IO-Compress.noarch 0:2.021-1.el5.rf set to be updated
--> Processing Dependency: perl(Compress::Raw::Bzip2) >= 2.021 for package: perl-IO-Compress
--> Processing Dependency: perl(Compress::Raw::Zlib) >= 2.021 for package: perl-IO-Compress
---> Package splint.i386 0:3.1.1-16.el5 set to be updated
--> Running transaction check
---> Package perl-Compress-Raw-Zlib.i386 0:2.021-1.el5.rf set to be updated
---> Package perl-Compress-Raw-Bzip2.i386 0:2.021-1.el5.rf set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================
Package Arch Version Repository Size
=============================================================================================================================================
Installing:
perl-IO-Compress noarch 2.021-1.el5.rf rpmforge 238 k
replacing perl-Compress-Zlib.i386 1.42-1.fc6

Updating:
splint i386 3.1.1-16.el5 base 1.5 M
swig i386 1.3.29-2.el5 base 2.9 M
Installing for dependencies:
perl-Compress-Raw-Bzip2 i386 2.021-1.el5.rf rpmforge 108 k
perl-Compress-Raw-Zlib i386 2.021-1.el5.rf rpmforge 169 k

Transaction Summary
=============================================================================================================================================
Install 3 Package(s)
Update 2 Package(s)
Remove 0 Package(s)

Total download size: 4.9 M
Is this ok [y/N]: n
[/code]
priority in rpmforge.repo is set to 11
And priorities in CentOS-Base.repo are set according to centos wiki about rpmforge.
I don't know why it wants to replace perl-Compress-Zlib.i386 1.42-1.fc6 with perl-IO-Compress from rpmforge

pjwelsh
Posts: 2629
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: yum priorities problem

Post by pjwelsh » 2009/09/21 13:31:33

Edit: My original post was not correct.
I have had some similar issues with priorities recently (http://centos.org/modules/newbb/viewtopic.php?topic_id=22241&forum=37), but appear to have been a function of a local repo override.

Edit Edit: If you use the "yum -v ..." do you see the initial priorities exclusion and then a "simple update" allow?

osde8info
Posts: 123
Joined: 2007/11/08 11:26:17

Re: yum priorities problem

Post by osde8info » 2009/09/25 10:29:54

please also post output of

# yum list yum*

(which should look something like the following)

Loaded plugins: fastestmirror, keys, priorities
Repository dag is listed more than once in the configuration

Loading mirror speeds from cached hostfile
* extras: centosr3.centos.org
* updates: centosh2.centos.org
* base: centosf4.centos.org
* addons: centosb2.centos.org

Excluding Packages in global exclude list
Finished

Reducing CentOS-5 Testing to included packages only
Finished

458 packages excluded due to repository priority protections

Installed Packages
yum.noarch 3.2.19-18.el5.centos installed
yum-fastestmirror.noarch 1.1.16-13.el5.centos installed
yum-keys.noarch 1.1.16-13.el5.centos installed
yum-metadata-parser.x86_64 1.1.2-2.el5 installed
yum-priorities.noarch 1.1.16-13.el5.centos installed
yum-utils.noarch 1.1.16-13.el5.centos installed

osde8info
Posts: 123
Joined: 2007/11/08 11:26:17

Re: yum priorities problem

Post by osde8info » 2009/11/12 11:09:20

yum yum-priorities is still broken see new bug http://bugs.centos.org/view.php?id=4002

Post Reply

Return to “CentOS 5 - Software Support”