Kernel Panic (error opening /dev/console)

General support questions including new installations
Post Reply
Posts: 3
Joined: 2006/05/19 03:01:17

Kernel Panic (error opening /dev/console)

Post by linuxpyro » 2008/04/08 02:37:05

I'm helping admin a CentOS 5 install. Recently the root password was lost, so I used Knoppix to go in and add a new md5 hashed password.

The machine has two 160 GB IDE drives, set up for raid 1. I mounted the / partition in Knoppix, using this command:

mdadm --assemble /dev/md3 /dev/hda3 /dev/hdb3

I then mounted /dev/md3 and made the appropriate changes. After I unmounted md3, I ran this command:

mdadm --stop /dev/md3

I then rebooted. However, I now get a kernel panic. Here are the last few lines:

Error opening /dev/console: No such file or directory
Trying to use fd 0 instead.
WARNING: can't access (null)
exec of init ((null)) failed!!!: Bad address
Kernel panic - not syncing: Attempted to kill init!

I tried remounting in Knoppixb and checking the file systems, but this did not help. Does anyone have any ideas?

Posts: 100
Joined: 2005/05/16 21:27:57
Location: Utah

Kernel Panic (error opening /dev/console)

Post by cormander » 2008/04/18 06:02:00

In your centos filesystem, make sure you have the /dev directory, and go into that directory. If you don't have the "null" and "console" files, run this:

mknod null c 1 3
mknod console c 5 1

This creates those devices. Reboot into centos afterwords.

Post Reply

Return to “CentOS 5 - General Support”