selinux problem - Input is not proper UTF-8

Support for security such as Firewalls and securing linux
Post Reply
woow
Posts: 16
Joined: 2012/02/08 19:37:19
Location: Greece (old one)

selinux problem - Input is not proper UTF-8

Post by woow » 2012/04/07 11:24:29

I have recently added support to fcgi with httpd and after that I'm full of those messages in the

/var/log/messages file:

[quote]Apr 7 14:19:47 secure setroubleshoot: SELinux is preventing /bin/ps from search access on the directory 2(r). For complete SELinux messages. run sealert -l 54675ba6-bca8-414f-85ad-d6557d55023f[/quote][Moderator edit: Changed [i]code[/i] to [i]quote[/i] tags to wrap long line.]

[code]$ sealert -l 54675ba6-bca8-414f-85ad-d6557d55023f
Entity: line 53: parser error : Input is not proper UTF-8, indicate encoding !
Bytes: 0x85 0x3C 0x2F 0x74
<tpath>2(r)</tpath>
^
failed to connect to server: xmlParseDoc() failed
[/code]

Can someone give an idea?

Thank you Very Much.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

selinux problem - Input is not proper UTF-8

Post by pschaff » 2012/04/07 13:15:27

[quote]
woow wrote:
I have recently added support to fcgi with httpd and after that I'm full of those messages in the
[/quote]

How did you go about doing that? Seems you have broken something. A google on the [url=https://www.google.com/search?q=sealert+Entity+line++parser+error++Input+is+not+proper+UTF-8%2C+indicate+encoding+!&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial&client=firefox-a&safe=active#q=sealert+Entity+line++parser+error++Input+is+not+proper+UTF-8,+indicate+encoding+!&hl=en&safe=active&client=firefox-a&hs=gYW&tbo=1&rls=org.mozilla:en-US:unofficial&prmd=imvns&tbas=0&source=lnt&sa=X&ei=1jyAT5izK8jIgQfPwMTdBw&ved=0CBkQpwUoAA&bav=on.2,or.r_gc.r_pw.r_qf.,cf.osb&fp=d5b0fb9cd82eac&biw=1293&bih=762]error[/url] turns up some obsolete bug reports, but if the search is limited to the last year, nothing recent except this thread.

woow
Posts: 16
Joined: 2012/02/08 19:37:19
Location: Greece (old one)

Re: selinux problem - Input is not proper UTF-8

Post by woow » 2012/04/16 16:42:19

yes, actually after some reboots the problem solved automatic!
still get some messages of ps which I managed to restrict via modifing the policy.. :-)

ty

Post Reply

Return to “CentOS 6 - Security Support”