Page 1 of 1

PAM pam_deny.so error

Posted: 2016/11/24 19:14:56
by fr0st
Hi,

I'm facing a problem today on a server (CentOS release 6.6 (Final) 64bits), I receive this kind of syslog message:

PAM adding faulty module: /lib/security/pam_deny.so
PAM unable to dlopen(/lib/security/pam_deny.so): /lib/security/pam_deny.so: cannot open shared object file: No such file or directory

So I tried to search pam_deny.so and I find him in /lib64/security/ instead of /lib64/security/

What can I do to fix this problem?

Thank you

Xavier

Re: PAM pam_deny.so error

Posted: 2016/11/24 23:15:42
by Whoever
I see both /lib/security/pam_deny.so and /lib64/security/pam_deny.so on my system. As you might expect, one is the 32-bit version and the other 64-bit.

What does this command return:

Code: Select all

rpm -V pam.i686

Re: PAM pam_deny.so error

Posted: 2016/11/25 14:28:49
by fr0st
Hi,

rpm -V pam.i686
package pam.i686 is not installed

I guess I have to install this package?

Thanks
Xavier

Re: PAM pam_deny.so error

Posted: 2016/11/26 23:30:01
by Whoever
What are you running that is 32-bit?

It seems odd to me that pam.i686 would not have been installed if libraries required for 32-bit support has been installed.

Re: PAM pam_deny.so error

Posted: 2016/11/28 11:59:51
by fr0st
uname -a
Linux xxxxxxxxx 2.6.32-504.el6.x86_64 #1 SMP Wed Oct 15 04:27:16 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/redhat-release
CentOS release 6.6 (Final)

I've installed this distribution and few days later I got a pam error. I didn't do anything special in between.

Re: PAM pam_deny.so error

Posted: 2016/11/28 12:14:23
by stevemowbray
CentOS 6.6 is old, unsupported and full of critical security bugs.

The current CentOS 6.8 plus updates is only a "yum update" away and will fix the critical security problems and might fix your problem.

Re: PAM pam_deny.so error

Posted: 2016/11/28 12:18:14
by TrevorH
Also, yum install pam.i686