Network problem. New install of CentOS 6 in VirtualBox

Issues related to configuring your network
Post Reply
Posts: 1
Joined: 2011/10/28 21:16:26
Location: UK

Network problem. New install of CentOS 6 in VirtualBox

Post by technoboi » 2011/10/28 21:43:18

I've read the postings which refer to incorrect MAC addresses resulting in network problems. I've checked that out and that is not the cause. This is not a cloned box it is a new install.

I've installed 'CentOS 6' in VirtualBox(VB) on 2 different machines. I get exactly the same problem on each.
If I go to 'Setup' eth0 is shown and I can do the device set up etc. However, if I run 'ifconfig -a', I see no eth0. Further, if I run 'service network restart', I get "Device eth0 does not seem to be present, delaying initialisation".
I normally set the VB network to 'Bridged' but I have also tried 'NAT'. It makes no difference - still no network.
I have CentOS 5.5 running Elastix as another 'guest' with no problem. Centos 6 is the only OS where I have ever had a network problem in VB.

Please can any one help? I should add that i am much more out of the Debian stable than 'Red Hat' so please take that into account with any replies. :-)
Thank you.

Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Network problem. New install of CentOS 6 in VirtualBox

Post by pschaff » 2011/10/30 02:53:35

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

CentOS-6 now uses NetworkManager rather than the network service by default. Does this FAQ sound relevant?

[url=]2. Why does my Ethernet not work unless I log in and explicitly enable it?[/url]

Also mentioned in the [url=]CentOS 6.0 Release Notes[/url].

Post Reply

Return to “CentOS 6 - Networking Support”