[SOLVED] Broadcom wifi driver not working

Issues related to configuring your network
Post Reply
Posts: 1
Joined: 2011/07/27 00:31:11

[SOLVED] Broadcom wifi driver not working

Post by jdancer » 2011/07/27 00:52:35

Can't believe I spent most of day googling and reading how to get my Broadcom wifi working on a new CentOS 6 install.

So, let me tell you how I got it working and typing this message via wifi:

Read http://www.broadcom.com/docs/linux_sta/README.txt

From the above README, type the following as root:

chkconfig network off
service network stop
chkconfig NetworkManager on
service NetworkManager restart
tar xzf
make clean
make install
depmod -a
insmod wl.ko (or reboot)

You should see your wifi light up now.

Startup the NetworkManager application and copy the MAC address for eth1 from ifconfig and paste it in the Device MAC Address field in the Wireless tab.
Click on the Wireless Security tab and select the type of Security your wifi router uses and enter your wifi router access point password in the Password field.
Check mark the Connect Automatically check box if you eth1 to start up on bootup.

It's very important you blacklist br43 and ssb. I got stuck on ssb for the longest time.

Good luck!

User avatar
Forum Moderator
Posts: 9324
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

[SOLVED] Broadcom wifi driver not working

Post by AlanBartlett » 2011/07/27 00:59:03

An even better way would be to read the [i]CentOS[/i] wiki -- the [url=http://wiki.centos.org/HowTos/Laptops/Wireless]wireless networking[/url] page, [url=http://wiki.centos.org/HowTos/Laptops/Wireless/Broadcom]Section 3.1[/url].

Post Reply

Return to “CentOS 6 - Networking Support”