Page 1 of 1

How to add a range of ip's in CentOS 6?

Posted: 2017/08/03 07:38:01
by linuxNewBie_010
I have been trying to add range of ip's on my dedicated server which has CentOS 6 x64

Following are the ip's which are assigned to my server.

Primary IP Block
IP Addresses: -


Secondary IP Block(trying to add these ip's)
IP Addresses: -



This is how my /etc/sysconfig/network-scripts folder looks


So far I have tried adding a range file(as u can see in the above img) named ifcfg-eth0-range0.

It has the following:

Code: Select all

But when I run "service network restart" command it shows the following error

Code: Select all

Bringing up interface eth0:  Determining if ip address is already in use for device eth0...
: integer expression expecteds/ifup-aliases: line 332: [: 194
: integer expression expecteds/ifup-aliases: line 339: [: 194
I asked support they said I need to check my ifup-aliases file and correct the error on the shown lines, but that file is untouched and is stock/default file how can it have error?