IP Aliasing issues

Issues related to configuring your network
Post Reply
SpaZMonKeY777
Posts: 1
Joined: 2017/04/26 23:57:14

IP Aliasing issues

Post by SpaZMonKeY777 » 2017/04/27 00:04:06

Hey all, first time to these forums! Just as a preface, I am a self-taught linux noob and while I do know quite a bit, some things are far over my head... So keep that in mind :P

So I rent a dedicated server from OVH, use it for some game servers and website hosting, have had it for a year now (had a different host prior for about 4 years, but OVH had a better deal for me last year). I also have a set of IP's from OVH that I use and aliased to my server for different servers I run and sites, all of which have worked fine for almost a year now.

But while I was at work today, my wife called and said everything went offline and had no connection/ping. Sure enough, after I got home, our main server IP works fine and we have connection, but all my IP's that were aliased no longer are pingable. I checked all my eth0:X files, all are still setup as they should be and were before, neither of us made any changes or anything since it was originally setup, but it suddenly won't work now? I tried rebooting our machine, disabling the firewall, among a few other small things, but I am stumped at the moment.

Anyone have any ideas or things I can try? I am running CentOS 6.8 currently, and can provide any other needed info. Thanks!

Macenger
Posts: 23
Joined: 2016/10/18 08:29:57

Re: IP Aliasing issues

Post by Macenger » 2017/04/27 07:35:12

Run a packet capture(tcpdump) on the interface and verify whether it receives the icmp request and responds. The following filter should help:

# tcpdump -s0 -nnei <parent interface name> icmp

If it doesn't receive OR it receives and responds, then it's likely something in the packet route is blocking. Running a traceroute with ICMP should help to identify after which hop the packets fails:

# traceroute -I <ip>

Post Reply

Return to “CentOS 6 - Networking Support”