Not able to send packages from client to the server

Issues related to configuring your network
Post Reply
jcesarpabreu
Posts: 1
Joined: 2017/04/18 06:40:22

Not able to send packages from client to the server

Post by jcesarpabreu » 2017/04/18 07:16:37

Hi all,

I really need your help on this, if possible.

(a short background) I have a project at collegue where I have to setup a CentOS server with the following services:
*DHCP
*SAMBA
*SSH (this runs by default)
*SQUID + DANSGUARDIAN

All these services are up and running, but the only one that is not WORKING is the squid = dansguardian. I can see that the windows client is able to reach the server (192.168.1.11) but not the GW (192.168.1.1), but I'm able to login from windows client to my CentOS server via ssh (SSH is working), samba is working and the server is assigning the IP to the client (192.168.1.50):

eth0 is spreading dhcp to my LAN 192.168.1.0/24 and eth1 is the LAN connected to the modem, 10.0.0.0/24 (this interface is dhcp-enabled):

DEVICE=eth0
NM_CONTROLLED="yes"
ONBOOT="yes"
BOOTPROTO="none"
IPADDR=192.168.1.11
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
NETWORK=192.168.1.0
HWADDR=00:0C:29:FF:7B:D1
PEERDNS=no
TYPE=Ethernet
PREFIX=24
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME=eth0
UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03
----------
[root@cerberus /]# cat /etc/dhcp/dhcpd.conf
#specify domain name
option domain-name "cerberus.local";
#specify DNS server ip and additional DNS server ip
option domain-name-servers 8.8.8.8, 4.2.2.2;
#specify default lease time
default-lease-time 600;
#specify Max lease time
max-lease-time 7200;
#specify log method
log-facility local7;
#Configuring subnet and iprange
subnet 192.168.1.0 netmask 255.255.255.0
{
range 192.168.1.50 192.168.1.254;
option broadcast-address 192.168.1.255;
#Default gateway ip
option routers 192.168.1.1;
}

SERVER TO WINDOWS CLIENT:
[root@cerberus /]# ping 192.168.1.50
PING 192.168.1.50 (192.168.1.50) 56(84) bytes of data.
64 bytes from 192.168.1.50: icmp_seq=1 ttl=128 time=0.344 ms
64 bytes from 192.168.1.50: icmp_seq=2 ttl=128 time=1.33 ms
64 bytes from 192.168.1.50: icmp_seq=3 ttl=128 time=0.346 ms
64 bytes from 192.168.1.50: icmp_seq=4 ttl=128 time=0.380 ms
64 bytes from 192.168.1.50: icmp_seq=5 ttl=128 time=3.68 ms

WINDOWS CLIENT:
Ping to the server:

C:\Documents and Settings\Administrador>ping 192.168.1.11
Haciendo ping a 192.168.1.11 con 32 bytes de datos:
Respuesta desde 192.168.1.11: bytes=32 tiempo<1m TTL=64
Respuesta desde 192.168.1.11: bytes=32 tiempo=62ms TTL=64
Respuesta desde 192.168.1.11: bytes=32 tiempo<1m TTL=64
Respuesta desde 192.168.1.11: bytes=32 tiempo<1m TTL=64
Estadísticas de ping para 192.168.1.11:
Paquetes: enviados = 4, recibidos = 4, perdidos = 0
(0% perdidos),
Tiempos aproximados de ida y vuelta en milisegundos:
Mínimo = 0ms, Máximo = 62ms, Media = 15ms

GATEWAY
C:\Documents and Settings\Administrador>ping 192.168.1.1
Haciendo ping a 192.168.1.1 con 32 bytes de datos:
Tiempo de espera agotado para esta solicitud.
Tiempo de espera agotado para esta solicitud.
Tiempo de espera agotado para esta solicitud.
Tiempo de espera agotado para esta solicitud.
Estadísticas de ping para 192.168.1.1:
Paquetes: enviados = 4, recibidos = 0, perdidos = 4
(100% perdidos),

IPCONFIG:
C:\Documents and Settings\Administrador>ipconfig /all

Configuración IP de Windows

Nombre del host . . . . . . . . . : colossus
Sufijo DNS principal . . . . . . :
Tipo de nodo . . . . . . . . . . : desconocido
Enrutamiento habilitado. . . . . .: No
Proxy WINS habilitado. . . . . : No
Lista de búsqueda de sufijo DNS: cerberus.local

Adaptador Ethernet Conexión de área local :

Sufijo de conexión específica DNS : cerberus.local
Descripción. . . . . . . . . . . : VMware Accelerated AMD PCNet Adapter

Dirección física. . . . . . . . . : 00-0C-29-99-73-2F
DHCP habilitado. . . . . . . . . : No
Autoconfiguración habilitada. . . : Sí
Dirección IP. . . . . . . . . . . : 192.168.1.50
Máscara de subred . . . . . . . . : 255.255.255.0
Puerta de enlace predeterminada : 192.168.1.1
Servidor DHCP . . . . . . . . . . : 192.168.1.11

Servidores DNS . . . . . . . . . .: 8.8.8.8
4.2.2.2
Concesión obtenida . . . . . . . : Martes, 18 de Abril de 2017 04:01:58a.m.
Concesión expira . . . . . . . . .: Martes, 18 de Abril de 2017 04:11:58 a.m.


I've been looking everywhere and maybe I'm missing a basic thing here, but if you could please point me out where I should take a look would be much appreciated.

Macenger
Posts: 23
Joined: 2016/10/18 08:29:57

Re: Not able to send packages from client to the server

Post by Macenger » 2017/04/27 07:49:57

Hi,

Apologies as I failed to understand what exactly isn't working. Two questions:

1. How was it identified that "squid = dansguardian" isn't working?

2. Eventhough the gateway isn't reachable from the windows client, I fail to understand why it's an issue with CentOS?

Post Reply

Return to “CentOS 6 - Networking Support”