[RESOLVED] Cent OS 6.0 on Dell 6510 with integrated gfx Ironlake: is it using correct driver?

Issues related to hardware problems
Post Reply
const451
Posts: 31
Joined: 2010/12/24 10:14:35
Location: Charlotte, NC

[RESOLVED] Cent OS 6.0 on Dell 6510 with integrated gfx Ironlake: is it using correct driver?

Post by const451 » 2011/08/24 21:00:26

Hello,

I've installed Cent OS 6.0 on Dell 6510 with integrated graphics card Ironlake. I've tried to install 5.6 but couldn't get the right resolution. Now it's using the correct 1080p resolution. I ran getinfo script and I see that it recognized the hardware "00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)" but I am not sure if it's using the correct driver.

Could someone take a look at my getinfo.sh output to check if it is the right driver, please.

Thanks!

http://pastebin.centos.org/37786 - getinfo.sh

http://pastebin.centos.org/37787 - /var/xorg.0.log

User avatar
AlanBartlett
Forum Moderator
Posts: 9324
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

[RESOLVED] Cent OS 6.0 on Dell 6510 with integrated gfx Iron

Post by AlanBartlett » 2011/08/25 00:03:31

I've had a look through the information that you have posted. With regards to the video driver, it looks as if it is correct.

You say that you have the screen in the correct (desired) resolution. Is there anything else that is a possible cause for concern?

You could perform a quick test by opening a terminal and then invoking [b]glxgears[/b]. Are they rotating smoothly in the un-maximised graphical window? Rotating smoothly in the maximised graphical window? Now minimise the window and let the program run for a bit longer. From the displayed statistics, you will notice the FPS rate change depending upon the window size.

From my [i]Dell Latitude E5500[/i], with dual video controllers --

[code]
[ajb@Duo2 ~]$ lspci -m | grep -i graphics
00:02.0 "VGA compatible controller" "Intel Corporation" "Mobile 4 Series Chipset Integrated Graphics Controller" -r07 "Dell" "Device 0263"
00:02.1 "Display controller" "Intel Corporation" "Mobile 4 Series Chipset Integrated Graphics Controller" -r07 "Dell" "Device 0263"
[ajb@Duo2 ~]$ glxgears
3573 frames in 5.0 seconds = 714.469 FPS
3587 frames in 5.0 seconds = 717.134 FPS
3590 frames in 5.0 seconds = 717.951 FPS
3640 frames in 5.0 seconds = 727.876 FPS
3592 frames in 5.0 seconds = 718.323 FPS
3587 frames in 5.0 seconds = 717.290 FPS
3592 frames in 5.0 seconds = 718.352 FPS
3588 frames in 5.0 seconds = 717.465 FPS
3613 frames in 5.0 seconds = 721.795 FPS
3744 frames in 5.0 seconds = 748.731 FPS
3586 frames in 5.0 seconds = 717.083 FPS
3593 frames in 5.0 seconds = 718.560 FPS
3585 frames in 5.0 seconds = 716.996 FPS
3595 frames in 5.0 seconds = 718.913 FPS
3586 frames in 5.0 seconds = 717.113 FPS
3591 frames in 5.0 seconds = 718.127 FPS
3574 frames in 5.0 seconds = 714.682 FPS
^C
[ajb@Duo2 ~]$
[/code]

const451
Posts: 31
Joined: 2010/12/24 10:14:35
Location: Charlotte, NC

Re: Cent OS 6.0 on Dell 6510 with integrated gfx Ironlake: is it using correct driver?

Post by const451 » 2011/08/25 03:38:49

I had problems with video card when installing 5.6 on this laptop before and I want to make sure v.6.0 using the right driver . Also, on my laptop the fan is spinning at full speed all the time so I want to make sure the gfx driver is not the culprit.

It's slower than yours but it looks like it runs smoothly, that's what I got:

301 frames in 5.0 seconds = 60.099 FPS
300 frames in 5.0 seconds = 59.852 FPS
300 frames in 5.0 seconds = 59.854 FPS
300 frames in 5.0 seconds = 59.850 FPS
300 frames in 5.0 seconds = 59.854 FPS
296 frames in 5.0 seconds = 59.183 FPS
299 frames in 5.0 seconds = 59.652 FPS
300 frames in 5.0 seconds = 59.853 FPS
300 frames in 5.0 seconds = 59.853 FPS

User avatar
AlanBartlett
Forum Moderator
Posts: 9324
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: Cent OS 6.0 on Dell 6510 with integrated gfx Ironlake: is it using correct driver?

Post by AlanBartlett » 2011/08/25 13:13:29

The graphics driver looks to be o.k.

[quote]
Also, on my laptop the fan is spinning at full speed all the time so I want to make sure the gfx driver is not the culprit.
[/quote]
I don't think there is any connection.

const451
Posts: 31
Joined: 2010/12/24 10:14:35
Location: Charlotte, NC

Re: Cent OS 6.0 on Dell 6510 with integrated gfx Ironlake: is it using correct driver?

Post by const451 » 2011/08/25 14:04:34

Thanks for your help!

User avatar
AlanBartlett
Forum Moderator
Posts: 9324
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: [RESOLVED] Cent OS 6.0 on Dell 6510 with integrated gfx Ironlake: is it using correct driver?

Post by AlanBartlett » 2011/08/25 15:46:08

You're welcome.

For posterity, this thread is marked [RESOLVED].

Post Reply

Return to “CentOS 6 - Hardware Support”