[RESOLVED] Thinkpad L412 & CentOS 6

Issues related to hardware problems
johnrdavisjr
Posts: 40
Joined: 2010/05/26 16:44:22

[RESOLVED] Thinkpad L412 & CentOS 6

Post by johnrdavisjr » 2011/07/11 14:02:05

Just wanted everyone to know that I have a Thinkpad L412 with an i3-370 & an AMD HD5145. I have installed the driver kmod-r8192se from elrepo to get wireless working. I had to install gcc and rpm-build in order to build the ati binary driver. After I installed the driver, I had to run an aticonfig --initial, then i ran an aticonfig--px-igpu to invoke the powerXpress feature to switch graphics. I have noticed that there is a significant delay when moving windows, and to be honest it is running a bit warm, but I only used it about an hour. I will report back by the end of the week. So far, everything works well. Great product, as always guys and gals!

JR

User avatar
AlanBartlett
Forum Moderator
Posts: 9325
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: Thinkpad L412 & CentOS 6

Post by AlanBartlett » 2011/07/11 22:53:31

[quote]
I had to install gcc and rpm-build in order to build the ati binary driver.
[/quote]
Why? :-o
What is wrong with the relevant [url=http://elrepo.org/tiki/kmod-fglrx]kmod package[/url] from the [url=http://elrepo.org]ELRepo Project[/url]? [img]http://www.centos.toracat.org/ajb/tmp/oops2.gif[/img]

johnrdavisjr
Posts: 40
Joined: 2010/05/26 16:44:22

Re: Thinkpad L412 & CentOS 6

Post by johnrdavisjr » 2011/07/13 16:46:22

I saw that, I just didnt know what version that kmod was on. I need something that is AMD driver 11.4+. so I can use PowerXpress with my laptop.

I would love to use that kmod, any ideas what version EL Repo is on?

johnrdavisjr
Posts: 40
Joined: 2010/05/26 16:44:22

Re: Thinkpad L412 & CentOS 6

Post by johnrdavisjr » 2011/07/13 19:40:30

N/m, I found it. The El Repo Driver is at 10.12. They have made huge advancements since then, and 11.4 is fairly stable plus it gives us the ability to use PowerXpress( essentially optimus for linux) and actually increased my battery life by 30 - 45 min.

User avatar
TrevorH
Forum Moderator
Posts: 29932
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Thinkpad L412 & CentOS 6

Post by TrevorH » 2011/07/13 21:37:50

Which ELRepo are you looking at?

[code]
# yum --enablerepo=elrepo list kmod-fg\*
...
Installed Packages
kmod-fglrx.x86_64 11.1-1.el5.elrepo installed
Available Packages
kmod-fglrx.x86_64 11.6-1.el5.elrepo elrepo
kmod-fglrx93.x86_64 9.3-1.el5.elrepo elrepo
[/code]

So that's got 11.6?

User avatar
AlanBartlett
Forum Moderator
Posts: 9325
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: Thinkpad L412 & CentOS 6

Post by AlanBartlett » 2011/07/14 01:24:58

[code]
[ajb@Duo2 ~]$ sudo yum --disableplugin fastestmirror --enablerepo elrepo\* list available kmod-fg\*
Loaded plugins: priorities, refresh-packagekit, rhnplugin
Available Packages
kmod-fglrx.x86_64 11.6-1.el6.elrepo elrepo-testing
[ajb@Duo2 ~]$
[/code]
Specifically that version of the package is in the [b]elrepo-testing[/b] repository.

johnrdavisjr
Posts: 40
Joined: 2010/05/26 16:44:22

Re: Thinkpad L412 & CentOS 6

Post by johnrdavisjr » 2011/07/14 12:10:33

Thanks Alan, I didn't think to look in the testing branch. Installing now. Thanks a ton.

johnrdavisjr
Posts: 40
Joined: 2010/05/26 16:44:22

Re: Thinkpad L412 & CentOS 6

Post by johnrdavisjr » 2011/07/14 14:44:13

Just wanted to report back, that the latest Catalyst in the testing branch of EL-Repo is 11.6 and successfully installed on my laptop, and am using PowerXpress with NO LAG, unlike the binary blob(even with generating a package).

Thank you su much Alan for your work!

If you would like you can close this. Anyone want me to post my config for the laptop? If so, let me know and I can post whatever information you would like.

User avatar
AlanBartlett
Forum Moderator
Posts: 9325
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: [RESOLVED] Thinkpad L412 & CentOS 6

Post by AlanBartlett » 2011/07/14 23:44:24

[quote]
Thank you su much Alan for your work!
[/quote]
I'll accept your thanks on behalf of [b]NedSlider[/b], who is the maintainer of all the video driver packages for the [i]ELRepo Project[/i]. :-D

[quote]
Anyone want me to post my config for the laptop? If so, let me know and I can post whatever information you would like.
[/quote]
Perhaps you would consider writing it up as a section for the [i]CentOS[/i] wiki [url=http://wiki.centos.org/HowTos/Laptops]laptops[/url] page?

NedSlider
Forum Moderator
Posts: 2896
Joined: 2005/10/28 13:11:50
Location: UK

[RESOLVED] Thinkpad L412 & CentOS 6

Post by NedSlider » 2011/07/16 22:03:41

[quote]
johnrdavisjr wrote:
Just wanted to report back, that the latest Catalyst in the testing branch of EL-Repo is 11.6 and successfully installed on my laptop, and am using PowerXpress with NO LAG, unlike the binary blob(even with generating a package).

Thank you su much Alan for your work!

If you would like you can close this. Anyone want me to post my config for the laptop? If so, let me know and I can post whatever information you would like.[/quote]

Thanks John for the feedback.

Given some positive reports, I've now moved the 11.6 drivers from testing to the main elrepo repository.

I will also try to keep them updated too so running 'yum update' with elrepo enabled will automatically keep them updated for you.

Post Reply

Return to “CentOS 6 - Hardware Support”