[SOLVED] CentOS on HP H8-1455 H4A25AA#ABA

Issues related to hardware problems
Post Reply
bislinkscom
Posts: 8
Joined: 2014/02/24 14:05:14

[SOLVED] CentOS on HP H8-1455 H4A25AA#ABA

Post by bislinkscom » 2014/02/24 14:14:42

I managed to install Centos 6.5 64bit along side Windows 8.1 on this machine.

Much to my surprize, I found that the NIC is not recognized.

The network card is Qualcomm Atheros AR8161 PCI-E Gigabit Ethernet Controller (NDIS 6.30)

Any help, please....

User avatar
TrevorH
Forum Moderator
Posts: 29443
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS on HP H8-1455 H4A25AA#ABA

Post by TrevorH » 2014/02/24 14:39:23

ELRepo have drivers for the Atheros chips. Take the output of `lspci -nn` and head to http://elrepo.org and follow their instructions to find the correct driver for your device. You'll need to download it and carry it via usb stick or something...
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

bislinkscom
Posts: 8
Joined: 2014/02/24 14:05:14

Re: CentOS on HP H8-1455 H4A25AA#ABA

Post by bislinkscom » 2014/02/24 16:32:51

TrevorH wrote:ELRepo have drivers for the Atheros chips. Take the output of `lspci -nn` and head to http://elrepo.org and follow their instructions to find the correct driver for your device. You'll need to download it and carry it via usb stick or something...
Got into kernel panic after installing kmod-alx-0.0-2.20121003.el6.elrepo.x86_64.rpm

NedSlider
Forum Moderator
Posts: 2896
Joined: 2005/10/28 13:11:50
Location: UK

Re: CentOS on HP H8-1455 H4A25AA#ABA

Post by NedSlider » 2014/02/24 18:51:01

bislinkscom wrote:
TrevorH wrote:ELRepo have drivers for the Atheros chips. Take the output of `lspci -nn` and head to http://elrepo.org and follow their instructions to find the correct driver for your device. You'll need to download it and carry it via usb stick or something...
Got into kernel panic after installing kmod-alx-0.0-2.20121003.el6.elrepo.x86_64.rpm
Why did you install such an old version?

Please install the latest version of the driver:

http://elrepo.org/linux/elrepo/el6/x86_ ... x86_64.rpm

which should work fine with 6.5

Thanks

bislinkscom
Posts: 8
Joined: 2014/02/24 14:05:14

Re: CentOS on HP H8-1455 H4A25AA#ABA

Post by bislinkscom » 2014/02/25 22:41:47

Yeah, I didn't realize until I encountered the kernel panic.

Anyway, I re-installed 6.5 on this machine, and successfully set up the network using the latest driver.

Thank you very much.

Post Reply

Return to “CentOS 6 - Hardware Support”